Volume button not controling the HTPC anymore

kodi

#1

Be sure to read https://yatse.tv/wiki/debug-yatse-kodi-remote to provide necessary logs and information.

Issue description:
Not sure when it happend, but it’s been a week or so.
As the topic says volume buttons now no longer controls the volume in yatse with it running and watching something as it used to.

Logs:
Got them, but not sure how they would help here since it’s not working.

Screenshots:
https://photos.app.goo.gl/HU5cksK1Xc2KVktp7

Additional information:
Used to work, a week or 2 ago and now it’s not working anymore.
Phone: Galaxy S8
(SM-G950F)
Oreo (8.0)

LibreELEC (Official)
V. 9.0.0


#2

Don’t you think that logs are here specially when things are not working???

Without logs what do you want me to tell :slight_smile: There’s maybe an issue, maybe not, maybe a setting changed, maybe not. All I can do.


#3

Well i ment that the logs might not be usefull if you cant see me trying to turn up or down the volume.
The first time i tried to make a log i activated debug mode, and tried to turn the volume up and down before i ended debug mode, and it did not make a log, so i guess that yatse dident see it. The log i made here i enabled debug mode, then i tried to turn the volume up and down using the buttons.
I then did turn the volume up and down in the app befor i ended the log to make it registre.

debug-20190224_122249.zip (6.8 KB)


#4

From the logs Yatse is always running from so the screenshot showing the global device volume is irrelevant :slight_smile:

To control volume outside Yatse you need both options show notification and use lockscreen. It does not seems that you have them enabled.

Inside the application it seems that you have enable the option No volume keys that disabled the volume keys in Advanced Settings/Advanced.


#5

You where right about the last one and i disabled that one, mostly i use them from outside Yatse and when in the app i just use the ones inside.
But it seems like i got the other 2 enabled, and like i wrote it just happed sometime and used to work.


Just to be clear, these are the ones you ment, and they had to be enabled like they are?


#6

Yes but if you are inside Yatse and have disabled the key it’s normal they don’t work.

If you have issue outside Yatse then I need proper logs showing usage of the buttons with Yatse minimized and the notification showing.


#7

Ahh sure, let me just make those. :slight_smile:


#8

There you go, if you can see all my actions in the log i put in a “start”, i pause/play then minimize, try to change the volume, and end the debug after.

debug-20190225_144523.zip (8.3 KB)

EDIT: Forgot the notification, here you go.


#9

Logs shows no issue looks like something is getting the focus or intercept things.

If you screen off does the buttons works? If you then screen on is Yatse showing the current media background / image ?


#10

Nope, the buttons do not work, with screen off, at the lockscreen, nor with just the screen on.
Everything else with Yatse is working as expected.

I’m almost done doing a factory reset of the phone, i’ll get back to you if it’s working after.


#11

Okay it’s working now and we can close this topic for now. :slight_smile:
Want me to do another log to see if anything changed or?


#12

Just to be sure that I see what I’m supposed to see yes it would be nice :slight_smile: Thanks.


#13

Here you go. :slight_smile:

SS of it working now.

And the log.
debug-20190225_213628.zip (10.0 KB)


#14

Thanks a lot with some more words to reach 20 chars :stuck_out_tongue:


#15

Did you find what was different?
Now it’s sadly back, and havent changed a thing since yesterday.

And a new debug log.
debug-20190226_191650.zip (104.1 KB)


#16

Are you sure you do not install some other application that could override the keys or request audio focus?


#17

Well i cant be sure, but i’ve been over what i got installed, and if i do i got no idea what it would be.
Also like you see on the screenshot is it the “normal” media it controls and not another app.
To add to that i installed Yatse as the last app, and it was working, and the day after it was not working anymore, and haven’t installed anything new since then. :thinking:


#18

Does it work after a phone reboot?

Do you start Yatse before or after the media start?

Will need more details if you can reproduce else there’s not a lot I can do from the logs all is OK :frowning:


#19

I can see if it works after a reboot when i get home from work.

Yatse is running before the media starts since i use WOL to start my HTPC.

I see if i can find out how to reproduce it (or fix it rather), since it seems like it reproduce by itself if i just give it time.


#20

No still the same, after reboot and after a shutdown it still controls the media.