Upnp Playlist, Play all and Play Random different outcome

Upnp Playlist, Play all and Play Random different outcome.
Random just shows Lounge for all tracks
Play all shows all track names.


debug.log (1014.7 KB)

Any idea why this happens and can it be fixed?
Thanks.

Video is private and you did not answer to previous issue.

But from quick look at logs this is a Kodi side issue not sure what you are trying to achieve.

What upnp source is that? (Why upnp at all in file actually :slight_smile: )

Oops, sorry can you see it now?
The fixes for my other issue didn’t work, playlist still disappears or music stop playing so I thought i’d try using upnp as that stores the playlist on kodi and not on the phone which works it’s just the filenames don’t show when choosing play random (can solve it by choosing play all and then hitting random on the player) but wondered why it does it and if it could be solved.

I’ve tried making an ftp source to to the other kodi box to browse folders but I can’t get it to connect.
All my music is on the sdcard that’s in the raspberry pi in the lounge.
Only way to play the folder through upnp is to create a smart playlist for that folder.

Now why do I use file mode?
Each year I make a folder with all the songs I’ve discovered in that year. The tracks could be from any year so using library / year won’t work.
I used to be able view files through upnp but the files folder isn’t there anymore (used to be there before I updated kodi)

Ok so yes this is a Kodi bug with UPnP and JSON not much I can do on my side.

For the other issue pretty sure there’s Samsung settings to fix it.

I’ll just create playlists for the years and use upnp / play all and use random button in yatse remote.
After using upnp I’ve noticed songs play perfectly normal, when using yatse cast it would play a split second of the song then go silent for a second then play the song normally, skipping to another track caused the same thing everytime and the gaps between songs were longer. It’s strange because for years it used to do the same thing but at the end of the track not the beginning.
I always thought it was something to do with the hifiberry card but upnp is faultless.

I’ll mark these as solved anyway as i’m happy to use upnp now I know playback is perfect and samsung phones are stupid.

The duplicate start is a Kodi bug with an addon, don’t remember all the details but it have been fixed in Kodi and I think it was backported to 18.

What Kodi version do you use ?

Both RPI2’s with OSMC, one in bedroom is kodi 18.3 (not enough space left to update)
Lounge one is 18.7

So it was indeed backported https://github.com/xbmc/xbmc/pull/17084 but 18.6 :slight_smile:

You need to update your Kodi @Si_45874

I deleted some stuff yesterday updated.
Another reason I didn’t update was because of an osmc bug that stopped my hifiberry outputting 5.1 (tested on another sdcard a month ago) which is fixed now with the latest version, only just tried playing some songs through yatse cast now after seeing your reply and the pausing at the beginning of songs is fixed. Thanks for letting me know!

I wonder if that bug also caused the playlist to vanish, played 4 songs so far and no long pauses between playing the next one, will keep my fingers crossed.

After saying that the music stopped, I pick up phone and noticed it was playing a jpg file!
It didn’t make the playlist disappear though it just stayed on it until I clicked next.
Never saw it playing an image file when it was happening before but could a dodgy image file cause kodi or yatse to abandon the whole playlist?

I’m going to delete all images from my music folders.

It stopped again but on an mp3 song, hitting pause/play doesn’t make it play but the graphic bars are moving up and down as though it’s playing and time is stuck at 00.00.00, moving the scroll bar also doesn’t make it play, wifi is still on.
Shame I haven’t got debug turned on :frowning:

Sounds like Kodi issues :slight_smile: But without logs hard to tell as I don’t know what you play and how.

debug-20200722_111152.zip (4.4 KB)
Here’s a log, it plays the song to the end then the time goes to 00.00.00 and doesn’t go to the next track.
I clicked next track and it played next track, skipped to near the end and when that song finished it did the same, didn’t play next track and time reset to 00.00.00.

Can you make a video of exactly what you do from starting Yatse to select renderer and play things ?

What do you mean by “renderer”?

You play from a kodi to another kodi right? You use the cast function in Yatse?

yes I play from a kodi to another kodi using cast function in Yatse.
I go to one kodi in yatse hit cast to another, menu / files / music / artists / orbital / play all.
It plays a 3 or 4 songs then goes weird, seems to happen with any folder I choose.

I’ll try casting using music library not file mode/folder and see what happens. I’m sure it’s only happens with file mode. I just noticed file mode selector was on but I only put it on this morning to test it.

Will be the same, your device freeze Yatse for no reasons :frowning:

Are you sure you followed properly https://dontkillmyapp.com/ ?
Please show screenshots of what you changed related to that.

I’ve done another video I’ll upload it in a bit after I’ve had some food. I did notice a bmp file when looking at playlist but when I first go into the folder before hitting play all the bmp file isn’t shown.

I’ll show you the other screenshots as well.

battery settings

starting music

I left music playing and went out leaving phone at home, came back 30 minutes later and playlist was gone. All songs add up to 126 minutes. Here’s the log of that.
playlist vanished.zip (317.0 KB)

When music stopped playing this morning but playlist stayed.
You’ll notice it says 20 files in the folder but viewing playlist shows 22 files and a bmp file is shown in the list.