Unable to connect to Kodi, possibly d/t firewall or router issues

Issue description: I’ve gotten the following error messages:

Unable to connect: Check your firewall configuration, that your Wifi router is not in isolation mode or change the port inside Kodi

Check the entered values, if host is running and your firewall. Press Help menu for details on configuring your host.

Logs: Attached from Kodi kodi.log (232.3 KB). Unable to get from Yatse, since I can’t get past the connecting to host screens.

Additional information: See Reddit post about Kore (before I learned about Yatse!)

tl;dr: I’ve done all of the following:

  • In Kodi:
    • Toggled “Allow remote control via HTTP”, “Allow remote control from applications on this system”, and “Allow control from applications on other systems”
    • Successfully allowed Zeroconf (toggled the setting “Announce services to other systems”) [after removing and reinstalling iTunes]
    • Enabled all UPnP/DLNA settings
    • Changed port to 8888
  • In Windows Defender Firewall:
    • Enabled public and private networks to communicate through the firewall for Kodi
    • Turned off firewall completely (temporarily)
    • Set up an Incoming rule for TCP 9090 and 9777
  • Quadruple-checked to ensure the IP Address and Port #, device name, username, and password are entered in Yatse as they are configured on my computer (I also tried without requiring authentication)

Screenshots: See Reddit post, but also including Yatse screenshots:



You say you changed port to 8888 but screenshots shows you are trying to connect to 8080 :wink:

Good catch! I was switching back and forth, but here’s a screenshot of 8888:

Per a Redditor’s suggestion, I also added 8888 to the firewall rule

I need Yatse logs to see more. Skip wizard select local device start free trial then you can enable logs.

You have a firewall / network issue, try to open the ip and port in chrome on that phone it may give a more precise error.

Log forwarded! Thanks for the info. I’ll look into the IP address/port thing right now

Ok so from the logs it’s a timeout, but auto detection works, so network seems ok.

Leaves Kodi issue like port already used and firewall issue.

Sorry, could you please say more about what I can do to help with the port issue? I’ve typed the following into Chrome on my phone: https://[computer’s IP address]:8888. It just times out.

Change the port to something else at all in Kodi. Kodi on windows is bugged as it can start even when the port is used.

But this looks like a firewall issue. Windows often assign wrong network types and you need to fully disable it to test, not just for a zone.

Sorry if I’m still misunderstanding – I changed the port in Kodi to 8887 and turned Windows Defender Firewall off (for both Public and Private network settings). The IP address:port thing is still timing out on my phone.

The you have something else that blocks traffic but it’s unrelated to apps. VPN on the phone, bad adblocker on the phone, other firewall / AV on Windows.
Or something on your wifi router that prevent wan to lan but that would be strange that mutlcast worked with that sort of settings.

Okay I just checked and made sure the VPN and adblocker on my phone were turned off (they were). I didn’t realize Windows had other firewall or anti-virus protection, but I just turned those off. With that done, Kodi and my phone still weren’t able to connect to my computer’s IP:port. One possibility is that I have a pretty complex network infrastructure where I live (a housing cooperative built for 140 people). If you think that’s a possible source of the issue, I can go to the office hours being held next Wednesday by those who manage the infrastructure. Or if you have any other ideas I’m open to trying those as well.

It could be if they have transparent proxying or stuff like that, but it’s strange that they let pass multicast.

In all cases there’s not much I can do to help until you can open the page on your phone browser.

Oof I’m so embarrassed - I was using my Ethernet IP address, whereas my computer was connected via wifi… The reason it may have gone automatically to Ethernet IP is that my Ethernet cable is connected but hasn’t been working for a month now. Apologies for wasting the time when I should have just done some fundamental research on IP addresses. Thanks again for all your help though, and I’m looking forward to exploring Kodi + Yatse!