Unable to connect to Kodi after going through configuration and troubleshooter

Issue description: Can’t establish connection between Yatse and Kodi

Unable to connect: Check your firewall configuration, that your Wifi router is not in isolation mode or change the port inside Kodi

Logs: Kodi log attached. I tried generating Yatse log after accepting the trial and going forward with “local device” but no logs were generated when I was trying to connect (unsuccessfully) to Kodi
kodi.log (54.1 KB)


Additional information:
While trying to solve the issue I took inspiration from this support post. Excluding the required prerequisites from the configuration guide, I tried:

  • Kodi
    • Enabled all UPnP/DLNA settings;
    • Enabled “zeroconf”;
    • Both port 8080 and port 8888;
    • Disable password (as seen in the screenshot).
  • Win Defender Firewall
    • Set up an Incoming rule for TCP 9090 and 9777;
    • Completely turn off firewall.
  • Router
    • Add an exception in firewall settings. Though I really don’t know what should I put as “Src port” as it keeps changing between every attempt to connect

My phone is connected (wi-fi) to the same network as my desktop (LAN cable). Desktop PC has a static lease “”

There’s always logs generated.

For the firewall usually you create an app profile. And 99% of the time the issue is that Windows think you are on a public network and apply public rules and not private ones.

I can’t tell much more than what the message on screen says. Nothing answers on that ip and port in the delay, since zeroconf work this really looks like a firewall isssue.

debug_Yatse.log (13.5 KB)
Ah yes, sorry. I believe I archieved it the first time I tried.

PC identifies my network as private. I also checked that my ethernet is the only active network (turned off Hamachi for example). As for making an app profile in the firewall, are you talking about Kodi? I checked and it does have an exception in the inbound section.

Either way, with the firewall disabled for troubleshooting purposes these shouldn’t be an issue? If the issue is on router side, I’m not sure what else can I do there.

You need to check the router if there’s an wifi isolation mode option.

Not much to do on Yatse side. As soon as you’ll be able to open the ip and port in chrome on the phone Yatse will work too.

I’ve scoured every single option in my Technicolor router and I couldn’t find the option for it… It could be missing some options as it comes from the ISP. I’ll buy a proper router (Asus RT-AX55) and give you an update. It has been long in the thoughts already, hopefully that’ll help.

So I’ve setup the new router:

  • Connected my phone through wifi and PC through LAN
  • Binded a specific IP address to my PC so it doesn’t change
  • Found the AP isolation setting. It is set to “no”.
  • Tried connecting, still the same issues.

Any other suggestions?


Use another port, disable firewall and AV.

When you’ll be able to open the ip and port in chrome on the phone Yatse will work.

It was most likely something to do with my Win 11 installation. After a fresh Win 10 installation (after formatting) everything works perfectly. Thank you for your efforts!

Unfortunately that was short lived. Yatse still has the connection in memory but can’t connect to Kodi anymore… So it probably has something to do with software that I installed, maybe it messes up the connection. I’ll try to experiment and get back to you if I find anything useful.

Found the culprit! It was “CheckPointVPN” that I use for work.