Stream from Plex via Yatse to Chromecast Audio / Video - file format not supported

chromecast
plex
cast

#1

Hi Tolriq,

first of all: thanks very much for work you are putting in Yatse. Great App!

Problem Description:
I have a Plex Server (Ubuntu 18) set up in my local network and I want to stream Audio/Video to my Chromecasts. In the past this has worked for Videos but not for music. Trying to stream today showed that it does not work for videos now, too. I always get the error message that the destination renderer does not support the file format of the media I want to stream. Here are some examples:




In the past - when audo streaming did work - i was listening an album and from one track to another the playback did stop with the same message. After hitting the play button for the same song that has caused the stop, the playback continued.

Hardware/Software:
Chromecast Ultra ( Castfirmware: 1.32.124602 )
Onkyo TX-NR676E built in Chromecast (Casfirmware: 1.28.102057)
Onkyo VC-GX30 built in Chromecast (Castfirmware: 1.28.101871)
Motorola Moto Z2 Force with Android 8.0.0
Yatse Version 8.5.5a/310654
Plex: 1.13.5.5291

Logs:
I did two tests. First one i tried to stream a video to the chromecast ultra. Second one: i tried to stream audo to chromecast ultra. Both of them failed with the same error message (file format not supported)
debug-20180818_162445_streaming_movie_to_chromecast_ultra.log (105.4 KB)
debug-20180818_163655_streaming_audio_to_chromecast_ultra.log (72.0 KB)

Yatse Settings:
force upnp streaming: enabled
alternative dlna parameter: enabled and disabled
highspeed wlan streaming: disabled

Thanks for your help and let me know if you need more information.


#2

I need Plex logs, from those logs, Yatse correctly identify transcoding and all needed actions and send the correct data to Chromecast.

Then there’s a problem between Plex and Chromecast but only Plex logs will show that.


#3

Here are the logs of the plex server. Plex Media Server.log (309.4 KB)


#4

Logs from Plex are strange.

It detect and wants Opus everywhere, when you try to play mp3 that are supported by Chromecast it says that it does not support that, that the mp3 is in fact opus and that opus needs to be transcoded to mp3…

I’ll dig up my chromecast ultra and see what I can reproduce.

Just is case have you tested to reboot the Plex server?


#5

I did a restart of plex right now but it did not change the behaviour. I also had a look at the transcoding settings but nothing catched my eye that could be helpful in this situation.


#6

Can you send me one of the failing mp3 in private so I try to reproduce with your media?

Maybe there’s something special in it even if I doubt.


#7

@other readers: I’ve just send some mp3 samples

back to topic: I found out that it is possible to set up a xml file for plex server in order to set the transcoding behaviour for specific goals. unfortunately, like the guys from this post:

I’m not able to find the location of the chromecast.xml. Maybe plex has changed the location or does not store transcoding preferences in xml files any more (due to new versions). Do you know more about that?


#8

Finally, I found the location of the transcondig profile folder of plex:

/usr/lib/plexmediaserver/Resources/Profiles

The default content of chromecast.xml:

<?xml version="1.0" encoding="utf-8"?>
<Client name="Chromecast">
  <!-- Author: Plex Inc. -->
  <TranscodeTargets>
    <VideoProfile protocol="http" container="mkv" codec="h264" audioCodec="aac,mp3" context="streaming" />
    <MusicProfile container="mkv" codec="opus" />
    <PhotoProfile container="jpeg" />
    <SubtitleProfile container="ass" codec="ass" />
  </TranscodeTargets>
  <CodecProfiles>
    <VideoCodec name="*">
      <Limitations>
        <UpperBound name="video.width" value="1920" isRequired="true" />
        <UpperBound name="video.height" value="1080" isRequired="true" />
      </Limitations>
    </VideoCodec>
    <VideoCodec name="h264">
      <Limitations>
        <UpperBound name="video.bitDepth" value="8" />
        <UpperBound name="video.level" value="42" />
      </Limitations>
    </VideoCodec>
    <VideoAudioCodec name="aac,mp3">
      <Limitations>
        <UpperBound name="audio.channels" value="2" />
      </Limitations>
    </VideoAudioCodec>
  </CodecProfiles>
</Client>

chromecast.txt (1.0 KB)


#9

Based on https://github.com/xtrap225/Plex-Chromecast-Ultra-Chromecast-profile/blob/master/Chromecast.xml I did the following modifcations to the chromecast.xml:

<?xml version="1.0" encoding="utf-8"?>
<Client name="Chromecast">
  <!-- Author: Plex Inc. -->
  <TranscodeTargets>
    <VideoProfile protocol="http" container="mkv" codec="h264" audioCodec="aac,mp3" context="streaming" />
    <MusicProfile container="mkv" codec="opus" />
    <PhotoProfile container="jpeg" />
    <SubtitleProfile container="ass" codec="ass" />
  </TranscodeTargets>
  <!-- Added directplayprofiles for music -->
  <DirectPlayProfiles>
    <MusicProfile container="mp3" codec="mp2,mp3"/>
    <MusicProfile container="mp4" codec="aac"/>
    <MusicProfile container="flac" codec="flac"/>
    <MusicProfile container="wav" codec="pcm"/>
  </DirectPlayProfiles>
  <CodecProfiles>
    <VideoCodec name="*">
      <Limitations>
        <UpperBound name="video.width" value="1920" isRequired="true" />
        <UpperBound name="video.height" value="1080" isRequired="true" />
      </Limitations>
    </VideoCodec>
    <VideoCodec name="h264">
      <Limitations>
        <UpperBound name="video.bitDepth" value="8" />
        <UpperBound name="video.level" value="42" />
      </Limitations>
    </VideoCodec>
    <VideoAudioCodec name="aac,mp3">
      <Limitations>
        <UpperBound name="audio.channels" value="2" />
      </Limitations>
    </VideoAudioCodec>
  </CodecProfiles>
</Client>

I get still the same error.


#10

Thanks for all the tries and info :slight_smile:
Will work on all that tomorrow :slight_smile:


#11

Having problem to reproduce.

Stupid question but this works via the plex app?


#12

Plex App >>> Chromecast Ultra >>>> WORKS
Plex App >>> Onkyo Devices (built in Chromecast) >>>>> WORKS NOT

…still I do have a long way to go to make everything work :tired_face:


#13

FINALLY…

Recently, I have switched to a newer smartphone

yatse (old smartphone) >>>> Chromecast Ultra WORKS
yatse (new smartphone) >>>> Chromecast ULTRA WORKS NOT

but how do i fix this?


#14

Well check Yatse transcoding options difference between the 2 phones :slight_smile:
Most are in General/Advanced.


#15

Settings are now identical between both phones. Unfortunately, i’m still not able to streamto chromecast devices with the new phone.

I will play around with the settings. In case I still do not achieve an improvement I will post my settings here.

EDIT: For your information

new phone: Motorola Moto Z2 Force (Android 8.0.0)
old phone: Motorola Moto Z (Android 8.0.0)


#16

Ok. I have set the same settings on the new phone as on the old one. But I still get the same error. Then I tried to change the language of the interface in order to make some screenshots of the settings. When I switched to English i saw that the app does not change the language of the interface. I assume that no matter which settings I set, the app does accept the settings. Does this make sense to you?


#17

Yes on some devices and Android 8 the language option does not work.

And since it’s against Google rules, I have not yet found time to find an hack for those cases :frowning:

Both phones have same options same Yatse version and one work and not the other ?
Have you tried to unsintall and install Yatse fresh on new device?


#18

Yes, both phones do have the same yatse version: 8.5.5a/310654. And they had the same Yatse settings.

I did not try to reinstall Yatse on the new phone, but I will do now.

One remark regarding the old phone: I am able to stream content (audio/video) but when i play a music album via chromecast it usually stops after 2…3 songs showing again the error “no compatible format”. Then I initiate the playback again where it did stop and then it works again… after 2…3 songs playback stops again


#19

again FINALLY :grin:

…deleting cache of yatse, uninstall and reinstall has solved the Problem. I will test now wheather playback will stop again after 2…3 songs. I hope this problem is solved, too. If this is the case then Yatse works better than the official plex app regarding streaming audio to chromecast.


#20

Ok, after streaming to chromecast did work for one evening, it did not work the day after. I was playing around with all the streaming/transcoding settings in order to solve the issue that playback stops after some songs that evening and in the morning nothing has worked.

Today I have deleted cache and data of the app - so no reinstallation - and now it works again but the issue of stopping playback between songs is still there. Now i will not change the default settings at all in order to find out whether playing around with the settings has caused the streaming not working at all.

Do you have any ideas how to fix this playback issue?