Stream from Plex via Yatse to Chromecast Audio / Video - file format not supported



Well I would need logs of that happening to see :slight_smile:


“Lucky”, it happend right after you asked for the logs :laughing:

debug-20180825_164219_streaming_audio_stops.log (517.5 KB)

It should be at the end of the logs.

EDIT: It makes no difference wheather I stream to original chromecast video or to built-in chromecast audio of the onkyo products I own.


2018-08-25 16:42:00.208 Verbose/PlexLogger: <-- [605] HTTP FAILED: timeout

Sounds like network issues, when you can to chromecast video can you please check the Chromecast screen and see what happens when the issue arise?
Does the Yatse app on Chromecast close? Or just sit there?


Ok, now streaming again does not work at all. I will clear the cache first.

Deleting the cache does not help but deleting app’s data. Now I will look what happens when playback stops on the chromecast video


You don’t change any settings and clearing data does repair?


Yes, i did not change the yatse settings at all. The fix was deleting app data.

But I did change the dns settings of my smartphone: For DNS1 i use a raspi pi with pi-hole for blocking advertisment. DNS2 was set to I have changed DNS2 to pi-hole, too. So I will now also stop changing any network settings… :sweat_smile:


When the playback issue happens I can see the name of the next song on the screen and a loading bar and after that the screen shows just the round yatse logo.

The app shows that it is still connected to the chromecast, like this:

When I hit the song that does not play on the app, the playback continues with this song like nothing happend


Can you send me new logs including the click on the song that continue?

This really sounds like a network issue, but Yatse should continue with the next song.

Playlists only stop after 5 errors normally.


Ok so no actually for Chromecast I stop directly.

So the issue is on Plex side with transcoding, at some point it fails or locks and the media does not start, and it does not even answer to Yatse queries.

The main question is why Plex want to trancode mp3 to opus when mp3 is fully supported and works natively.

I’ll send you a test APK by mail that override Plex settings and allow mp3 as direct stream to see if the mp3 plays and the issue no more occurs.


Thanks. I have sent you my mail address by pm.


APK sent bla bla 20 characters :slight_smile:


Ho and with the normal production APK things to test:

  1. Reboot plex server to unlock blocked transcoding sessions
  2. In Yatse remove the plex host and add it again, it will generate a new token and seen as another user from Plex so should unlock this too it it’s that. (Probably the same thing as clearing Yatse data as there’s no other thing that could explain that it fix it)


I have tested the beta APK for the first time now. Still the same error. Playback stops after some songs and start again when I manually hit the song in the app that’s next in the list.

2018-08-25 22:54:42.726 Verbose/PlexLogger: <-- [193] HTTP FAILED: timeout
2018-08-25 22:54:42.737 Verbose/PlexLogger: <-- [497] HTTP FAILED: timeout

debug-20180825_225516_streaming_audio_stops_restart_beta.log (1.0 MB)


Well logs confirms that there’s no transcoding.

So your Plex stop answering at random points for no reasons :frowning:

Do you have some firewall or special plex configuration? The issue is no more something I can fix on my side now :frowning: