Problem using Yatse with a Jellyfin server when streaming to upnp device

It’s not emby related but as jellyfin was a Fork from emby and as I do not found a jellyfin tag, I use the “emby” one.
Also sorry, if I missed a similar issue but I did a quick search and do not found anything. Thanks

Issue description:

As I listen music through Yatse from my Jellyfin server all behaves well. The problem happens when I start a cast to my amp by UPnP. No matter which song I chose, it’s always the last Jellyfin song played before that which is played by the amp. So we have the amp displaying that is playing “A” while Yatse say it’s playing “B”.

I got no clue why it happens.

debug-20210728_200710[1].zip (17.2 KB)


Additional information:

From the logs Yatse does sends the proper metadata but after your receiver no more send them back so I have no way to know what it understood and what it displays;

I’ll need more details about what you mean by last played by Jellfyin, like you mean without playing from Yatse?

Yes, sure.

Here is an example, I listen during the day my music using my browser from my jellyfin server then stop. In the evening, I take Yatse and launch a random mix and yatse launch the play but this is the last played song from Jellyfin that’s loaded and played by the amp then not the one launched by Yatse.

Maybe a problem within Jellyfin, but if I use the jellyfin app or simply using a browser and cast from there to my amp then this is fine. Only using yatse third app that the wrong song is played.

Ok that’s really strange, from the logs I can see an undocumented error 600 after loading the media but it accept the load and the play as it start playing.

Looks like your receiver act strangely :frowning: All I can guess would be that the receiver does not like the urls without a file extension and ignore the mime types.
Unfortunately I’m in holiday so can’t send you a test build until a few days.

Ok, thanks you for the answer. I’ll try to see what’s the difference between Jellyfin and Yatse waiting your test build.

Here is the log from a session starting using the browser.
If that could help

jellyfin-dlna.log (16.9 KB)

Just in case what type of flac is it and does your receiver support it?

Seems Jellyfin transcode while your receiver says it support any kind of flac files.

My Amp support FLAC (16/44 to 24/192). And I sent classic FLAC 24 bits, I don’t think it has something special about the files.

I’m not sure of what to search :confused:

May beJellyfin transcode because of a wrong setup, that’s possible. I’m trying to see if I could avoid that when possible.

Can you try with some mp3 to see ?

Hum strange, I do not start the play using a MP3.

Here is the logs:

debug-20210801_230517[1].zip (118.9 KB)

Also, I don’t know if it could help my amp is a Marantz NR1504

Hum yes same accept then same error 600 (undocumented and without a message) but yes after says no media present and don’t play.

There’s definitively something it does not like, can you try to uncheck the option alternative dlna flags just in case ?

The other thing would be to add the jellyfin server from it’s local address and port so that it does not use the let’s encrypt certificate that maybe your device does not recognize.

Ok, I’ll try that.

In “Streaming settings” → Advanced → Alternative DLNA parameters, is unchecked. I’ll try to enable it and retry.


And just in case here’s a test APK that adds a file extension to the urls.

Yatse-playstore-armeabi-v7a-final.apk (8.5 MB)

Ok, solution to use the local address is fine.

That bothers me a bit as I want to use it seamlessly from my house or elsewhere but I’ll find a solution, either switch to classic http or get accept the let’s encrypt certificates to my device ^^

You can add 2 times the same host in Yatse to address that too.

Yatse is more advanced as support more cast targets so use it’s own renderers discovery and as such can’t have the server only side that can detect that the renderer and servers are on same network and so use the non https local address.

Not sure there’s many workarounds I can offer on Yatse side except to add proxying but that would use a mega tons of battery on the phone :frowning:

About the certificate, it’s not a problem on android ? It seems that let’s encrypt certificates is fine on mine, just checked using the following url: So, I guess it’s my amp which is a bit dated ^^.

I’ll use 2 hosts, for internal and external usage and see. It’s not that horrible to switch so I can survive :slight_smile:

Thanks for your reactivity and support, I do not buy much on store but never regrets to paid this one.

Yes your certificate is valid but letsencrypt ones are not supported on old devices as the root cert was unknown then :frowning:

Maybe there’s a firmware update for your device that will fix that.

But seeing they return undocumented error codes without messages I’m not sure they are very good on that side :frowning:

Only problem of 2 hosts is when you have large library it takes more space and more time to syncs :frowning:

I wonder does Yatse support basic http authentication ? In addition of the normal auth of Jellyfin