Image sync betweek Yatse and Kodi doesn't work on odd images (Raspbian)

Issue description: If you open a folder with pictures using the “Picture Sync” feature between Yatse and Kodi the first picture opens and sync successfully, but if I swipe to the next picture on Yatse it shows the picture but on Kodi it goes to Home. Then if I swipe again to the next picture it successfully shows it on both Yatse and Kodi. (This behavior is difficult to explain so I recorded a video that is attached to this thread)

Logs:

Screenshots: Here is a link to the video where you can see how to reproduce it: https://vimeo.com/371008826

Additional information:

  • My setup: I’m running Kodi on vanilla Raspbian 10 (Buster) on a Raspberry Pi 3B+. Kodi version is 18.4. When I got the logs Yatse was on 9.3.5 but I just updated to 9.4.0 and the issue persists. The images are on a Samba share but I also tried on a local folder and its the same. The images used for this are these: https://imgur.com/gallery/eaPKy
  • Only happens on Raspbian. I tried to reproduce the issue on a Windows machine using the same version of Kodi (18.4) and the feature works as expected. Since this issue only happens on Kodi on my Raspbian system please let me know if it would be a good idea to also post this on the Kodi Forums.
  • Why is this important for us. We are trying to use Kodi and Yatse as a replacement for our church’s display/presentation system and having this to work is one of the last steps for a complete replacement.
  • You guys are awesome! I didn’t mention this at the begging of the post but Yatse is great. Since we started to use Kodi Yatse is our go to remote, we use it everyday. Keep the good work. :green_heart:

I tried to follow the guide to open a support request as best as I could. If you need me to clarify anything or get new logs please let me know :wink:

Something that I forgot to mention is that I’m still able to swipe (from the bottom of the screen upwards) to “send” the image, even though it didn’t synchronize at first.

This is a Kodi issue with jpg files

2019-11-04 11:57:01.010 T:1629307104 NOTICE: DecodeJpeg: unable to decode smb://192.168.0.21/image-testing/08.jpg 540x304

You may want to remove some of your plugins then report to Kodi if it’s a supported version, else you may want to try Librelec / OSMC for your rPI.

Hi Tolriq! (Thanks for the quick response.)

I don’t think this is an Issue regarding the file format/decoding. Here is why I think this is not the case:

  • The timestamp doesn’t match when I reproduced the Issue. I reproduced the issue at 2019-11-04 15:29:28.774 T:1282400480, you can check the kodi.log file on line 2258 . Also Yatse logs don’t start until 2019-11-04 15:29:17.099.
  • If instead of tapping the first image I tap the one you mentioned in the logs ,it works fine, but as soon as I swipe (either right or left) the next image doesn’t appear unless I swipe upwards.
  • Also I tried with other set of pictures:
    • With only .png images it also happens.
    • With only jpg images it also happens.
    • With a folder with 5 copies of the same .jpg image (just different filenames) it also happens.

I do agree that is seems to be related to Kodi but it is triggered by the swipe event and does seem to be related to the specific picture set.

I’m installing LibreElec right now. Also I will be testing on my machine running Gallium OS (a distro based on Ubuntu). I will post an update after testing that.

If you have any other insights on what could be the cause I will refer them to the post on the Kodi forums threat.

Regards!

Yatse commands are all correct and Kodi always returns OK, I took an extract of the log but the issue is still the same.

I suppose they have an issue when starting to play a new image when one is already playing, hence the decoder issue as they probably don’t release something in time if it’s not generated by some addons or unofficial build.

You can easily long press an image then press play to not have to swipe then long press another image and press play too, you’ll certainly have the same issue.

Just finished trying on my machine (Ubuntu) and on LibreElec(Kodi 8.14) and it works just fine there :sweat_smile: . Since it is something specific to my setup I will mark your last answer as the solution. I will be working with the guys at Kodi from now.

I will share a link to the threat on the Kodi forums later and if I find a solution I will also post it here for future reference.

Thanks for your help :slightly_smiling_face: