Can't install Yatse


#1

Be sure to read https://yatse.tv/wiki/debug-yatse-kodi-remote to provide necessary logs and information.

Issue description:
Can’t install app

Logs:

Screenshots:

Additional information:
Android 5.0
Elephone p7000
Already had on the same mobile app working before hard reset. Now says that app can’t be installed. Says it’s compatible, download it’s made, then comes the message. What it could be? Thanks.


#2

Install are made by Play Store and 100% unrelated to Yatse.

Without the error code there’s nothing I can tell you except search for that code in Google for solutions.


#3

Ok, Thanks for your reply.

Here goes the error code.

Thanks again.


#4

Well as I said this not Yatse related at all :slight_smile:

So here’s the first answer from Google about this error: https://appslova.com/fix-android-504-error/


#5

I am also getting the same issue installing from Play Store
it’s either error -504 or error -910, Installing directly from apk returns error -11.

Installing older version of Yatse 7.8 from apk works without any issue, but not it cannot be updated since updates from Play Store will fail with error above.

Android 5.0.2
Xiaomi Redmi Note 3


#6

Click the link in the answer?

https://support.google.com/googleplay/answer/7513003?hl=en ?

This is a Play Store issue and nothing I can act on :frowning:


#7

Sorry, I am not blaming you or anything, I just need to find a solution for this issue as I have no luck so far.

I tried all those methods linked above with no avail. Clearing Play Store data/cache, Clearing Google Service Framework data/cache, Reset google account, even wiping dalvik-cache doesn’t seem to help.

The only step I haven’t tried is probably to do a factory reset, which I really want to avoid doing if possible.

Interestingly, Yatse version 8.8.8 installed just fine, but using adb to install 8.9.0 returns an error: Failure [INSTALL_FAILED_DEXOPT]

I recorded a logcat during installation, I hope someone with adb expertise can enlighten me on what the problem is :slightly_smiling_face:

logcat.log (15.9 KB)


#8

Your device is 64b capable so you should install the v8 version.

Please provide new logcat with that APK and I’ll see if I can forward to Google R8 team in case it’s an issue in their tool.


#9

@DmnzH ping as there’s no automatic mails on closed issues :slight_smile:


#10

Thanks for looking into this issue.

I got the same failure even with v8 adb returns with Failure [INSTALL_FAILED_DEXOPT], please see the new logcat attached.

Looks like the issue is probably related to these lines

F/libc ( 1991): Fatal signal 7 (SIGBUS), code 1, fault addr 0xffff00c7 in tid 2001 (Compiler driver)
.
.
.
I/AEE/AED ( 2064): pid: 1991, tid: 2001, name: Compiler driver >>> /system/bin/dex2oat <<<
I/AEE/AED ( 2064): signal 7 (SIGBUS), code 1 (BUS_ADRALN), fault addr 0xffff00c7

logcat.log (18.2 KB)


#11

@DmnzH please add a comment at https://issuetracker.google.com/issues/126056766 so that you can answer Google questions :slight_smile:


#12

@DmnzH can you confirm that your device have a mediatek chip and not a snapdragon?


#13

Yes, it is a mediatek