Yatse sometimes won't show Now Playing info from Plex HTPC

Sometimes I cannot see the Now Playing info in Yatse when connected to Plex HTPC.

A fix I’ve found is to cast from both Yatse and the Plex app at the same time. Then it will always show the Now Playing info.

Why does this happen, and any idea how to make it work without casting from both apps?

Screen recording of issue: https://0x0.st/oMxu.mp4

As the template says the logs are mandatory … I don’t know anymore how to make that more obvious.

Devs are not magical beasts, we can’t guess things from a video.

Pretty sure Plex returns invalid data in those cases but no logs no solution.

Sorry, I misread that as Kodi logs for some reason.

Here are the Yatse logs: https://0x0.st/oMxf.zip

I turned on debugging, clicked play (select), Now Playing did not pop up, then I stopped recording logs. Let me know if there’s something else I can do, thanks.

I need more complete logs, those show nothing not even the select.

Please have them also show the working part.

Okay, here you go: https://0x0.st/oMx4.log

I clicked select on the remote to play the episode (no Now Playing info,) then switched to Plex (Phone) App & connect. Switch back to Yatse & Now Playing info is showing correctly. Then I Pause/Play in Yatse. Finally, I switch back to the Plex (Phone) App and turn off casting. The Plex app asks me if I want to continue playback on my phone. I hit No and it stops the playback.

Not sure if my explanation is helpful/relevant or if you’d just like the logs. Either way, thanks for your time.

Hum the logs makes no sense and are missing some parts.

Can you please enable logs. Stop casting, force kill the app then reproduce the same as you just did so I have all logged ?

Sure thing.
debug-20220609_022335.zip (80.3 KB)

Started logging, then stopped casting. Force closed the app & relaunched. Selected to cast to Plex HTPC (to enable remote.) Then proceeded to follow the same steps as last time.

However, this time, at the end, my Plex app did not ask if I wanted to “continue playback on this device?” when I stopped casting from the Plex app. This time, Yatse still showed the Now Playing info after I stopped casting from the Plex app (that’s not always the case though.) I did another pause/play at this point.

I tried repeating my steps a couple of times, and the first few times, the Now Playing information was immediately correct, without needing to cast from the Plex app at all. (I realize when writing this, that it might have been useful to save those logs as well… let me know if that would help, I could try to reproduce it again.)

Ok so now logs makes sense.
This is indeed a Plex issue with what it reports.

When it does not work Plex says:

<MediaContainer commandID="2" location="navigation">
<Timeline address="" audioStreamID="49822" containerKey="/playQueues/548" controllable="subtitleStream,videoStream,audioStream,shuffle,repeat,stop,playPause,stepBack,seekTo,stepForward,skipPrevious,skipNext" duration="1318357" key="/library/metadata/14168" machineIdentifier="be6cff17c097b500b0a3fc7f5f73e81daafe47b0" playQueueID="548" playQueueItemID="32202" playQueueVersion="1" port="32400" protocol="http" ratingKey="14168" state="stopped" time="764805" type="video" videoStreamID="49821" />
<Timeline state="stopped" type="music" />
<Timeline state="stopped" type="photo" />

So that the video player is stopped and no more increase the time. Not sure what I can do / workaround here on my side :frowning:

1 Like

Thanks for checking it out! Makes sense that it is a Plex issue, as I have had no issues with your app on Kodi for 1+ year(s.) (I only switched to Plex HTPC because of frame rate issues on the playback device when using Kodi.)

Not sure if it’s possible, but is there a way to send an arbitrary keypress to Plex HTPC? (Example: Custom Command to send Spacebar to pause/play.) When I go to add a custom command, the only options are to Import from File (I do not have a file to import) or Add from HTTP commands plugin (I am a noob and I’m not sure how to properly use this plugin.)

Regardless, it’s not really that annoying to use the Plex App workaround, so I will probably stick to that if it’s not possible (or hard to configure) a custom command like this.

Thanks again for your time.

No it’s not possible, the plex control API is very very limited sorry.

But if you have issues with Kodi you should report to them so they fix, it will always works better.

1 Like