Yatse Remote starter won't start MrMC on Shield TV

Be sure to read https://yatse.tv/wiki/debug-yatse-kodi-remote to provide necessary logs and information.

Issue description:
let’s try to identify the problem

  1. when MrMC is active On my Shield TV I have no issues to controll it from Yatse via my mobile phone

  2. I also have no problem access the shield tv ip from my mobile device. (http://192.168.1.190:8080)

  3. the problem occure when MrMC is shut down. Also even when MrMC is up but minimised I send “wol” I get message wol sent to host, no error but nothing happen and MrMC is still in the background

  4. I forward port 8080 for that IP on my router but still no luck
    when sending “wol” command from Yatse remote starter (port 5600) I get NO errors, it syas wol sent host should start now
    but nothing happen

Logs:
2019-02-21 00:05:30.201 Verbose/StatusObserver: [email protected]: UI status changed to false from true
_ 2019-02-21 00:05:30.253 Verbose/NetworkManager: [email protected]: Network Status Check_
_ 2019-02-21 00:05:30.254 Verbose/NetworkManager: [email protected]: Not Wifi Only_
_ 2019-02-21 00:05:30.258 Verbose/NetworkManager: [email protected]: Status: true / WIFI_
_ 2019-02-21 00:05:31.547 Verbose/NetworkManager: [email protected]: Network Status Check_
_ 2019-02-21 00:05:31.548 Verbose/NetworkManager: [email protected]: Not Wifi Only_
_ 2019-02-21 00:05:31.549 Verbose/NetworkManager: [email protected]: Status: true / WIFI_
_ 2019-02-21 00:05:34.090 Verbose/KodiLogger: --> [710] POST http://192.168.1.190:8080/jsonrpc (61-byte body)_
_ 2019-02-21 00:05:34.091 Verbose/KodiLogger: --> [710] {“id”:668,“jsonrpc”:“2.0”,“method”:“Player.GetActivePlayers”}_
_ 2019-02-21 00:05:34.111 Verbose/KodiLogger: <-- [710] HTTP FAILED: java.net.ConnectException: Failed to connect to /192.168.1.190:8080_
_ 2019-02-21 00:05:34.113 Verbose/StatusObserver: [email protected]: No Widgets and no UI / Wear / MediaBrowser_

Screenshots:

Additional information:
Yatse remote starter wol port is 5600, this also the port on Yatse Remote
what else can I do?

Elad

Wol is UDP so state less protocol there’s no error even if no one receive the packet.
I always need full logs.
I need to see your Yatse remote starter configuration and I asked for more details about your network setup.

And obvious first test would be to see if that works with official Kodi first :slight_smile:

Hi you’re awake?? :slight_smile:


this is my starter configuration of corse when I test it I enable the sever it is on ly down when not needed as I don’t won’t it drain battery
what do you mean my network setup? I have regular wifi settings no port forwarding what so ever (If I need to connect remotely I have VPN on my router)
here is the latest log I have from last night
debug-20190221_004419.zip (3.7 KB)

best
Elad

Ok :slight_smile:

So you may have missread everything :slight_smile: The remote starter needs to be installed on the shield.

The word remote is because it is to be remote, on the shield there’s no battery issue :wink: There’s messages everywhere about not installing in phones / tablets as you can even see on this screenshot.

:hushed::thinking::roll_eyes::persevere::sweat_smile::scream::fearful::flushed::scream_cat:
have I missed any appology icon?

Tolriq
I am so sorry for waisting your time if that is the case…
I will try it tonight (am at office now) and let you know, I assime side loading is needed?

Elad

No it’s an TV application just install it from the shield Play Store as it should.

And yes it is the case, docs are clear :wink:

1 Like