Yatse does not play Spotify album from library

Hello,

The Spotify add-on has the possibility to export albums to library. Since the latest update when I browse the albums in Yatse and want to play the whole album it does not work.

The log is attached debug-20200621_153120.zip (4.7 KB)

Kodi log Is here:
pastebin.com/e42X5Jbp

I have also tested in in Kore, and it worked without problems.

Well seems like the plugin does not properly add the songs and Kodi can’t play the individual songs.
It should be reported to them so they can fix the implementation.

To play album with the hack long press them and select play.

1 Like

Hello Tolriq.

I confirm that presented solution works, thanks for advice. What is weird for me, that it worked before the update to current version.
Unfortunately the author of the Spotify add-on is not active anymore. I already tried to contact him -maybe you remember that you have given me some clues about the order if tracks taken directly from the add-on.
It’s a pity, that the add-ons with legal content are not supported good enough, especially that the Kodi authors are complaining that the piracy is killing Kodi…

The joy of Kodi :slight_smile:

And yes previously there was an hack that triggered the play album with tons of conditions.

It’s removed as no more needed in most of the cases, seems for spotify it’s still needed :frowning: