Yatse Chromecast Gen 2 not playing

Hi, having an interesting issue regarding casting to Chromecast. I have a Chromecast gen 1 which I can connect to and cast to fine.

Whenever I try to connect and cast to my Chromecast Gen 2, it connects (and on the TV, the “Y” logo comes up.) However, once I try to play something, Yatse acts like it is about to play (transport comes up) and the TV shows the movie I’ve selected with a loading bar, and a few seconds later it goes back to the “Y” screen, and the transport disappears on my phone as if nothing is playing (without me touching anything after hitting play or resume).

I’m kind of at a loss since it is happening to one chromecast and not the other, and I can’t find any other people having this issue at the moment. Found a thread about someone having “automatic offline mode” on causing the issue, but not the case here. Curious if anyone can help. Let me know if anything else is needed!

Logs
debug.log (130.0 KB)

It seems like this is probably the relevant bit from the debug log

2020-07-07 22:33:22.990 Verbose/ChromecastRenderer: Playback started successfully (true)
2020-07-07 22:33:24.164 Verbose/ChromecastRenderer: onStatusUpdated: [email protected] - 1 - 4 - true
2020-07-07 22:33:24.167 Verbose/AsyncRenderer: Media stopped: false / true [30.146741476046614/0]
2020-07-07 22:33:24.169 Verbose/StatusObserver: Status changed: 2
2020-07-07 22:33:24.169 Verbose/StatusObserver: Status changed: 2

From the logs all works ok, your Chromecast have issues either to reach Kodi or to play that file.

You may just need to reboot that device to fix this.

Hmm interesting…I guess I’m at a loss then, I’ve just tried rebooting all devices involved and did not seem to help. I appreciate you taking the time to look at my logs!

Well from logs Yatse check the media and image all is ok, then ask Chromecast to play the file, Chromecast says OK then a few seconds later says it’s idle without returning an error or anything.

Not much I can do on such scenario :frowning: It’s something internal to Chromecast does it works with other apps or files from a different source like your phone ?

So strange; to answer your questions- it does work when I playing from other sources or even pulling the same file straight from VLC on the same phone. I even tried factory resetting the Chromecast to see if that would help, same behavior…but like you said, not much you can do if there aren’t any actual errors! Anyway, I appreciate you looking into it. Maybe somebody else has had this happen and can provide an answer

Seems you are using Kodi 19 maybe try to update or revert to 18.7 ?