Yatse Call Plug in - No caller ID

I am a paid user of Yatse and love it. I use the Yatse Call Plugin to pause video when a call comes in but the plugin no longer displays the Caller ID on the TV. I have 3 identical Android devices on 3 TVs and on 1 TV, the plugin shows a box saying “Incoming call from ???”. On another TV, it doesn’t show any box at all. I haven’t tested the 3rd TV.

Sorry, I tried generating the logs in the Yatse app but it’s not generating anything when I duplicate the issue. When I look for the logs it shows “no file”.

Hoping you’re familiar with this issue and can provide some support.

There’s always logs generated as soon as you enable it, else Yatse would crash.

When you press the red entry in left menu it offers to send it by mail.

Without those logs there’s not much I can tell as no idea what your device is, what OS, was version of everything.

Thanks Tolriq. I have sent the logs via email. I was staying on the Advanced Settings screen after hitting the “Debug Mode” toggle, duplicating the issue and then disabling Debug Mode. I didn’t realize I had to exit right out of settings to get to the left menu again.

I do not see errors in them. Have you recently updated your phone to Android 10 or changed phone?

Can you check that the plugin still have the necessary permissions?

Ok so Google force the new permission even without targeting the sdk level.

Please test attached APK CallPlugin-final.zip (1.0 MB)

But as they do not allow the permission on Play Store except some very rare case I’m not sure this update will be allowed :frowning:

Hi Tolriq. Sorry for the delayed response. Yes, I believe that this may have started when I switched to a new phone with Android 10 and all my apps automatically restored on the new phone. Should I try uninstalling/reinstalling the Call Plugin from the Play store first or just uninstall and install the APK you provided?

You can just install this one over and start it so it ask for the new permission.

@Craig_Hunt so does it work?

Hi @Tolriq. My appoligies for not reporting back sooner. The updated plugin fixed the problem on device #1. It works perfectly. I am still not getting any notification at all on devices 2 & 3. All 3 devices are identical.

Then I’d need new logs :wink: But you probably disabled notification forwarding in the settings or forget to start the plugin once so it registers and request permissions.

I just emailed you new logs.
To get the caller ID working on Device 1 I had to manually run the Yatse Call Plugin to get it to ask me for the permissions.
However it is still not working on the other 2 devices (see logs from device 2). I made a couple calls during the debug gathering. I tried launching the plugin again thinking it might need to set permissions for each active device but it still doesn’t show the Caller ID. Thanks for your excellent support @Tolriq. Excellent products, excellent support!

Yes as said earlier you need to start the plugin to add the new permissions.

Ok so the plugin work but no caller id? Uninstall and reinstall the new plugin on those device and start them to give the 3 permissions.

Sorry. What gets installed on the devices? The Call Plugin is installed only on my phone (remote control). The 3 devices I am talking about are the Android boxes connected to my TVs (Running Kodi). Does something need to be installed on those as well?

Ok so you were not clear at all :slight_smile: It’s 3 Kodi not 3 phone :slight_smile:

Yatse only sends the message to the currently connected Kodi it won’t send to the 3.

Yes, I understand that.
I am switching Yatse to the active Kodi device, making a test call while a video is playing and watching that single TV. I realize that it is only going to pause/send notifications to only the 1 device that is currently ‘active’ in Yatse.
But…the caller ID information is only showing up on 1 of the 3 Kodi boxes. When I switch Yatse to Kodi devices 2 or 3 and do a test call - no caller id. Only on Kodi box 1.

What do you mean no caller ID? Yatse does not change depending on the host so nothing displayed at all? You probably have event server disabled on those device or a skin issue that does not show notificattion.

Thanks @Tolriq. That was it.
Kodi > Settings > Services > Control > “Allow remote control from applications on other systems”
This was disabled on the other 2 Kodi devices. I enabled it on each, made test calls and they both display the caller ID.

Thanks for the zip file. I had same exact problem with Yatse on Android 10 phone & KODI on Windows 10. No caller ID. That APK you posted solved the issue