Yate does not works properly when device (that host yatse) is in wifi access point mode

Hello Tolric,

First your app is awsome, second excuse me for my english.

I use my phone as wifi access point and internet GW to connect all my devices, including my raspi/kodi, but in this mode, my phone is not connected to a wifi network because it provides the network to others devices, and some stuffs don’t works, such as getting media playing status and controls and file browser is not available, but i can cast youtube videos or control kodi with arrow paddle.

So could you improve the way app check if kodi is available from remote app ?

It coud be very usefull for peoples like me that don’t use internet box :wink:

Merci a lot !

Uncheck the option wifi only ? :slight_smile:

Android does not consider that being on Wifi so no choice.

For the record on Android 9 this does not work yet since they blocked the hacks to detect this mode.

Humm, but if some controls works, for example, i can browse media and i can start/stop media playing from the arrow pad, so that mean network connectivity works and yaste can send request to kodi, so maybe it’s possible to force yaste to request kodi api even if it see that device is not connected to wifi network to get get current media status and file browsing ? or i missed something more compolicated ?

As written, to have Yatse forced to work without Wifi you just need to uncheck the option Wifi only on your host in Yatse.

There’s pictures in the Wiki :slight_smile:

indeed, i’m stupid, i don’t understood your explication, i have to improve my english, thanks a lot :wink:

On vas dire que vous etes Francais au hasard :slight_smile:

Il faut decocher l option uniquement en Wifi dans les parametre de l hote dans Yatse.

Rien de compliquer et logique vu que vous voulez fonctionner sans Wifi :wink: