Wrong artists shown under genre if "music genre to artist" setting is enabled

Issue description:
If “music genre to artist” setting is enabled, the list of artists under a genre does not only include album artists of this specific genre, but also artists which are an album artist under a different genre and are a track artist in the present genre.

Example: My library contains several albums with album artist “a-ha”, which are tagged with genre “Rock, Pop, Indie”. These are the main albums of the band. The artist a-ha has also a single track on an album in the genre “Soundtrack” (album: “The Best of James Bond”, track “The Living Daylights”).

When I enable “music genre to artist” setting and navigate to Genres -> Soundtrack, then “a-ha” is listed in the artist list. When I click on them, I see the list of all of their albums (which belong to a different genre, not the current genre I am in), but I do not see the James Bond soundtrack album with their track on it, because they are not an album artist of that album. I cannot navigate to that album at all, which has to do with the issue Album artists of compilation albums are not shown if "Music genre to artists" setting is enabled

Logs:
Please use logs and music DB from this issue (sent via email):

Screenshots:

Additional information:

Requires Kodi 19 to have proper song genres returned for Artists by Kodi.

Made a quick-and-dirty test with Kodi 19 alpha 2, and it seems to work the other way round now:

  • At first glance, the issue seems solved: if “album artists only” filter is enabled, wrong album artists derived from tracks are not shown anymore.
  • If “album artists only” filter is disabled, then only track artists are additionally shown, which are not also album artists in another genre (in my James Bond example from above, “a-ha” is not shown, but “Duran Duran” or “Shirley Bassey” is shown, as I do not have any other albums from them in my library). Track artists which are also album artists somewhere else are missing. So it is basically the opposite issue from before.

Also another issue persists: if an album artist is clicked on, then all albums across all genres from this artist are shown, not only the albums from the current genre. This is especially uncomfortable with the “Various Artists” artist, because there might be a lot of those throughout the library.

Genre -> artist stop here then all albums from artist are shown. If you want different behavior you can use smart filters this is on purpose and no plan to change that sorry.

For the rest it’s another Kodi “issue”, the song genre reported for a-ha is Rock, Pop and Indie so sountrack is not reported so it’s normal it’s not shown.
I deal with what Kodi returns and work with that data, I can not directly work at song level from Yatse as this would be insanely slow on the vast majority of low / mid range phones

Ok, I will try with smart filters then, although that involves a lot of extra clicks. I guess they will have to be enabled/disabled every time/for every different genre. I still find it counter-intuitive to not filter by the genre first selected, but that is your choice :slight_smile:

The reporting of the genres seems strange, maybe I can investigate with the Kodi guys. I understand that you cannot parse all the individual song data. What Yatse delivers is still way better then using a UPnP browser directly, because in that case all data has to be reloaded every time. I thought about that first in combination with Kodi custom nodes (because for example I would like to have Soundtrack genre ordered by album title directly, all other genres grouped by artist), but it seems custom nodes are not published via UPnP.

Ok so thanks for all the clarifications, at least I do understand now why certain things are as they are, and for sure you cannot fulfil every individual wish, otherwise it gets unmanageable :grin:

Thanks for your work!

Most choices are made for performance reasons.

Smart filters can be saved and loaded at any time you can easily reproduce Kodi custom node with them and smart playlists inside Yatse.