WOL over WAN not working correctly

Linux Arch + Kodi, static public IP, in the Yatse host settings I have local & public addresses with particular settings - forwarded port 9 to the computers port 9, provided the right MAC address.
WOL works well over local network.
WOL doesn’t work over WAN (outside the router). I can see in my Mikrotik settings the packet came from outside and is forwarded, but it looks like it is not in the right format.
Just for your information - WOL packet from pubic internet with any 3rd party android app or with any computer with particular software WORKS without any problem. After wake up Yatsee is able to connect to the computer with public address and is able to shut the system down.

Any idea why is this happening?
Thanks for any advice

Because Yatse correctly does WOL over WAN? :slight_smile:

WOL is a broadcast packet on LAN and a specific packet over WAN that is targeted for WOL proxy that will properly convert to WOL packet.
You never port forward WOL port as it’s not how it works normally.

Hello, thanks for your response. I’m using Mikrotik Routerboard and I have to have port forward in my firewall rules. If I don’t, every other WOL capable app isn’t working. I read more tutorias and every single one was forwarding this special UDP packet.

Edit: I disabled port forward for port 9… and only thing that happened is, that I am unable to wake up the computer over internet from any other app.

From microtik Wiki:


You need to do port forwarding + add static ARP entries or ip neight.

Those are hacks to forward real WOL packet across interfaces, but not how WOL over WAN normally work.

If I change to send WOL packet then I’ll break all the other users who properly support WOL over WAN.

I have done the ARP too… That’s why it works with any other app. I checked it the DDWRT tutorial, but nothing new for me. I’ll try investigate more about that and sniff for differences in packets from 3rd party apps and from Yatse.