WearOS Companion App does not communicate with main app

Hello,

I realize the WearOS Companion App might not be as widely used as the main App but at least on my Fossil Gen 5 (WearOS 2.0) I’m seeing a problem in the Yatse Companion App so I thought I’d mention it.

I seem to be unable to select a different Media Center (it’s the 3rd section when opening the App). Clicking on either my 2nd Media Center or local device doesn’t seem to trigger any action whatsoever. Normally I would include Logs but not sure how and if that even works on an Wear App.

Please let me know if you need further descroption, Screenshots or anything.

Thanks!

Well the template says logs are mandatory and screenshots :stuck_out_tongue:

Fair enough, should have done it from the beginning, sorry my bad :slight_smile:

Here goes the Screenshot:
screen

Here’s the Logcat extracted from WearOS, started from the time the Screen was activated until opening Yatse and clicking on another Media Center in the view from the Screenshot:

Have a nice day!

I meant the Yatse logs How to get debug information and open a proper issue everything the watch do is sent to Yatse, if the list is present then communication works.

Sure, Yatse Logs are here:

Watch was connected and I was opening the Companion App doing the same thing.

Hum this is really strange, and the rest of the wear app works?

There’s no error in the logs and no message at all passing.

A rewrite of the app is planned but still I’d like to figure this.

Would be nice if you could force kill Yatse and the wear app with yatse logs enabled then retry and include using some other button from the remote page on the watch.

Strange indeed, you are absolutely right. I was so focused on the one screen that I didn’t check all the other functionality. Actually none of the actions from the companion app work, checked it with browsing and volume from the first screen. Watch is connected via BT but Wi-Fi is on as well.

I did as you mentioned and started the Debug Logs, killed Phone and then companion app and restarted both and checked functionality:

Other Info:
Watch is a Fossil Gen 5 with WearOS 2.38. Might be unrelated but I had to reset the watch last week I’m not a 100% sure if the Companion App worked before the Reset, can’t tell anymore.

But if I’m the only one with that problem (?) and a rewrite is planned anyways it’s not the biggest issue to wait for that imho. I’m using the Main App much more often which works beatufilly :slight_smile:
But if you want to track it down more I’m also happy to help.

Guess I need to change the Topic Title :frowning:

Well the rewrite of the wear app would not change how it communicate with Yatse so this needs to be figured out :frowning:

Logs shows nothing wear related, like if Yatse does not receive the messages, I see that you use the P6Pro I hope they did not break something in last Android 13 :frowning: I do not have anymore a working physical watch to test. Hoping the pixel watch is affordable :stuck_out_tongue:

Will restart the emulators and everything and try with my P6P to repro and in all cases add more logs.

Oh yes, forgot to mention the Host Device but you’ve seen anyways. Yep, it’s the 6 Pro with the latest Android 13 Security Patch released this week. Could be, unfortunately I don’t have another Device/Watch combo to test with something <Android 13.

I’m actually hoping the same, also interested in that Watch :smiley:
Ok, thank you for taking a look at it, please ping me if you need anything.

Well the only last test would be to uninstall both and reinstall if you have time and motivation :slight_smile:

Sure, I could try that too if I have a bit of time this weekend :slight_smile:
The Companion App however I already uninstalled completely and re-installed it. At least it seems to show somehow the correct Media Center list etc. as seen from the Screenshot, just commands do not work.

Ok so just discovered Google Issue Tracker :frowning:

Too late for a fix in 11.1.0 but I’ll try to find a workaround for the release after.

1 Like

I’m sorry, haven’t had the time to re-install last weekend but I had that planned for the upcoming. Seems though that I don’t need to do that anymore.

Just Google being Google I guess :frowning:

Test APK on the next version thread, should work on Android 13 even if will consume more battery.

On another part Google said they might fix this in the coming week. But who knows.

1 Like

Hi,

I’ve installed the Beta on my Pixel 6 Pro and sideloaded the Companion App to my Watch.

Everything works great now from the Watch and it looks gorgeous with the new interface :smiley:
Thank you!

Ok so in theory Google fixed the issue with updated lib and play services.

Can you confirm with attached APKs N

Yatse-beta-arm64-v8a-final.apk (9.1 MB)
Wear-final.apk (1.1 MB)

1 Like

Hi,

yep, I can confirm that everything works with this version as well (at least on WearOS side). I think I tested all the functions and they all worked :grinning:

Ok that’s a good news :slight_smile: Thanks.

1 Like