Wear OS controls not showing media art

This is a support request, though I don’t think it is caused by an issue but probably due to a wrong configuration.

I am able to control my Kodi server via the Yatse application from my smartwatch (no problem so far); however, while I can see the art with other media players installed on my phone (e.g. disk cover art), with Yatse I can’t (it is only a white play/triangle system background, with the controls on the foreground).

NOTE: I don’t know if it is related - I could not make it work on my watch even by playing with the following options - but I would also like Yatse NOT to display the art as phone’s wallpapers (neither normal nor lock wallpapers), just on the notification bar (as it is configured for).

Summary of my desired configuration:
smartphone: art only on the notification bar, not as wallpapers (achieved with both yatse and other apps)
smartwatch: art displayed when showing the media controls (not achived with yatse, but achieved with other apps)

Is there any option in Yatse I need to tune to make this work?
PS: I really searched for this before creating this post (sorry if I missed any entry)

Thank you in advance and best regards.

Since you removed the template that explained that logs are mandatory and did not provide those logs there’s not much I can tell from your message.

There’s multiple places where things are shown and many are managed by the OS, without those logs and more details about where you see things it’s hard to point you anywhere.

Sorry, as I considered this more a doubt than an issue, I thought the logs would not be needed (I was obviously wrong). I start again:

=====>

Be sure to read How to get debug information and open a proper issue to provide necessary logs and information.

Issue description:
Yatse does not show the media art on my smartwatch.
Other applications do (e.g. Musicolet).
I disabled the “show art as wallpaper” yatse setting on my phone because my desired goal is:

  1. on the smartphone: art is only displayed on the notification bar (this is working fine with both Yatse and other media apps

  2. on the smartwatch: art is displayed when on the “media controls” screen (this works with other media apps but not with Yatse)

Logs:
debug-20210407_161653.zip (11.4 KB)

Screenshots:
Yatse


Musicolet

Additional information:
Smartwatch: fossil sport with wearOS 2.26
Smartphone: Samsung Galaxy S6 with Android 8.0.0
Yatse version 10.7.5

Ok so this is not the Yatse app but the Android one. When playing things on Kodi, you need to enable the settings publish media session.

Sorry if it is too obvious, but: how do I do that?
EDIT: The “General Settings > Publish media session” option is enabled in Yatse (if that’s the one you were referring to)

Hum that’s strange what happens if you disable the show notification settings in Yatse?

The notification disappears from the phone (as expected), but the player controls are still available in the smartwatch… however, the art as background still is missing.

It actually depends on your OS version :wink: But I’ll try to find my old watch and reproduce.

JFYI I’ve been playing with all the “general” settings that refer to wallpaper / notifications (including the “expert” ones), but without success :frowning:
At the end this is a “cosmetic” issue more than anything else; the controls - which are the important part - do work fine.
Thanks for your effort.

Found the issue it’s a side effect of Android Auto workaround :frowning:
Will fix for next release.

1 Like

Super,

Thanks a lot for your quick support