Voice Commands Never Work

No matter what I try, when I use the voice commands media isn’t found.

Attached is a log. Really simple command “Play Next Baby Daddy” I looked at the log and I see that the command is there but the actual media isn’t found. Help appreciated.debug-20180714_122503.zip (435.7 KB)

Well the agent wrongly understood the command as action= play and media= next baby daddy.

But strangely when I look at the agent logs it correctly shows that it understood tvshow play next.

Looks like a bug with caching in Dialogflow (Google tool I use without control over internals). I suppose it will be fixed there at some point but nothing I can action on my side since the logs shows it did find the correct thing :frowning:

It’s for all media I guess. I just tried with “play next containment” and it must be identifying the media as “next containment.”

Yep but nothing I can do, you can try other formulation like play next episode of baby daddy.

I just tried to open an issue on dialog flow but the issue sending returns an error :frowning:

Fair enough. Thanks for the help. I’ll monitor future releases to see what kinds of results I get.

This is not tied to the Yatse appplication and so not tied to any release of Yatse, i’m using the Google AI thing. They can fix at any time or never fix.

As I said you need to try with different sentences as it will trigger different reactions from AI.

BTW next episode can also be handled as resume.

So saying resume baby daddy, should work.

Sweet that worked. One feature request now - if you’ve already started an episode and stopped it, “resume” should start from where you left off. Instead, it seems like it starts from the beginning of the next episodes.

But all in all, the problem is now resolved. As always, you’ve got the answers.

resume does resume unless it does not yet have the correct resume point only reason it would start the next episode would be that it’s seen as played.

Please open another issue with logs so I can see more.


Was finally able to reach Dialogflow support and they acknowledged the bug and provided a configuration workaround while they are fixing the root cause :slight_smile:

Can you please try again and confirm it works better ?

Yeah it seems like it’s working now! Thank you.