"Various artists" does not show up as an artist in every genre where it has an album

Issue description:
I think Kodi creates a localized artist for albums using various artists. In my case the artist is name “Verschiedene Interpreten” (German localization). I have the “genre to artist” setting enabled in Yatse. I would now expect that in every genre which has an album from the “Verschiedene Interpreten”, this artist also shows up. But that is not the case, it only shows up in one (in my case of four) genres.

This is probably a Kodi API issue, I only wanted to make sure.

Sent via email, subject: Yatse logs for issue 3399
While logging, I first moved to a genre which contains the “Verschiedene Interpreten” artist and entered it. Afterwards I moved to two other genres which are supposed to contain this artist, but they do not. These genres are even named under the artist name when I enter “Verschiedene Interpreten” through the first genre.


Additional information:

My music library - I have the feeling you might want to have that :slight_smile:

(edit: link removed)

On Kodi 19 I have it in all for genre Jass/ Soundtrack / Kompiliertes / Classical

Interestingly, in my Kodi it is also there. But (seemingly) not in Yatse. I upgraded yesterday to Kodi 19 (before I opened the issue), so I just thought I might remove and add the host configuration in Yatse to have a clean sync.

After that I searched more properly for the artist - and now I found it in other genres as well. Probably it was there in the first place, but it turns out it is not sorted properly in Yatse. I would expect to find it under “V” (like “Verschiedene Interpreten”, or at least “Various artists”), but this is where I found it:

  • Classical: between Gonzales and Karajan
  • Jazz: between Holmes and Hubbard
  • Soundtrack: between Holmes and Horner
  • On the artist page: between Hopper and Horner

So it seems it is sorted somewhere with the letters “HO…”. Does that mean anything to you, or is that because some track artist in the Various Artist albums starts with these letters?

It is properly shown at V place in all lists. Are you sure you sort by name ?

Yes, I am, see screenshot (“Verschiedene In…” on the right).

Ok so you have enabled the use of sort names for artists in Kodi settings and the sort name for that artist is “Horner, James”

You need to fix your Kodi database :slight_smile:

Well, this is interesting. I have four compilation albums which include the works of James Horner (actually all of them are soundtracks by James Horner which include one or more titles by other artists). All of those have

  • album artist: James Horner
  • sort album artist: Horner, James

This is quite inconsistent on Kodi side I guess that they take the sort album artist of a random (probably the first) compilation album as sort artist for “various artists”. Especially as “various artists” is a flag, not an artist entered in the artist field.

Sorry to ask, but you have more experience with them: do you think that is a “user error” (“Don’t set an album artist for compilations!”), or should I open a ticket with the Kodi team?

For music you should always ask in Kodi forum music part :slight_smile:

Dave is active and reactive, since it’s all tag based, it’s probably a TAG issue, but don’t know if it’s a user error or flaw in processing.

By the way, Kodi itself seems to display it correctly, at least in the web interface. Will look later on the RPi.

The web interface probably does not take in account the use sortname for artist as I’m probably the only one to do that :wink:

But yes Yatse display should be consistent with Kodi display as I check Kodi settings and use Kodi values.

I checked on Kodi, it is indeed the same as in Yatse.

So solving as all works as intended, Dave on Kodi forum will probably see why Kodi act like that.