Using Voice Assistant plugin to play Jellyfin music on Google Home Mini

I have successfully used the plugin and IFTTT to command my Mini to play a requested song from my Jellyfin library (on a synology NAS), but the song plays on my phone. Can the IFTTT applet be configured to have the song play on the Mini instead? Thanks for any help.

It’s covered in the wiki Yatse voice assistant integration (Google Home, Amazon Alexa)

You need to pass the proper arguments see the manual integration part.

Thanks. Glad to hear that my goal is reachable. I’ve read through the manual integration instructions. Does the solution lie in changing the renderer? As reflected in the log below, I’m selecting “2” as my host (my Jellyfin LAN server is the 2nd entry listed under Settings/Manage hosts/Media Centers), and “2” as renderer because I’m speaking into the Home Mini and want it to play on the Home Mini (“Local Device”). These settings still result in the song playing on my phone, not my Mini. I tried other combinations and either nothing plays at all or it plays only on my phone. I wouldn’t think the target render would be “6” as I’m not casting from the Mini, but even if “6” is correct, I don’t know where to find the “Chromecast Id” for the Mini (I tried its MAC address, but that didn’t work).

Am I getting close, or completely off base???

Here’s the log for the settings described above:

2022-02-18 16:01:28.870 Info/FirebaseMessagingService|Message received [1]|{parameters={“host”: 2, “rendererType”: 1}, command={“queryText”:“play the Beatles”,“languageCode”:“en”,“action”:“music.play”,“parameters”:{“song”:"",“genre”:"",“album”:"",“artist”:“The Beatles”,“sort”:"",“genre-original”:"",“artist-original”:“the Beatles”},“allRequiredParamsPresent”:true,“fulfillmentMessages”:[{“text”:{“text”:[""]}}],“intentDetectionConfidence”:1}}

Well you say you put 2 as renderer but the logs shows you put 1 :wink:

Example: {"host": 2, "rendererType": 6, "rendererId" : "abcdidofthechromecast"}. You can find the HostId in Yatse host configuration and rendererId in manage renderers.

The host id is not the order it’s the value shown in the list under the name.

Same for the renderer you need to enter the rendererId.

Thanks so much. Per your instructions, I found the rendererId for the Mini and added it to the string. That did the trick. All working nicely on the Mini.

Trial and error on what voice commands it likes, but so far I’m able to have it play individual artists, songs, and albums. Is there a particular command for playing a selected playlist in random mode?

Most commands are listed Yatse Voice Commands :slight_smile:

For the playlists there’s no commands as the Google engine would not really be able to understand random names and matches them.