Use fully-qualified domain name to connect to Jellyfin server

Issue description:
I have jellyfin running on a VPS behind an nginx reverse proxy. I’d like to connect to it using the domain name (, however Yatse only provides an option to connect with an IP address and port number, meaning I have to expose the port Jellyfin is listening on.

I’ve tried just putting the domain name in the IP address box with a random port number but that doesn’t work (the app doesn’t allow leaving the port number empty). I made sure https was enabled when doing this so that’s not the issue. Should that work / is there another way to do it or does this need to be implemented?

You can enter domains too.

And the port for http is 80 the port for https is 443. More network question than Yatse.

Thanks yes changing the port number to 443 did the trick.