Use device hostname instead of ip adress

I can’t use static ip in my local network, I need to use dynamic ip adress.
So, I’d like to manage the hosts of my android devices at yatse using the device name instead of ip adress.
I’d tried ten different ways and I didn’t have sucess.
Bellow you can verify a list with dhcp clients connected to my network router.

yatse

In the following image you can verify the error in yatse during host configuration.

When I use the ip adress 192.168.0.110 it connects like a charm!

Any idea about what is wrong when I use the hostname?
I know that yatse will work with hostname if my network configuration allows DNS resolution. I think that my network allows DNS resolution, but is there any test that I could do to verify that?
Another doubt is related with the hostname of android devices, should I use the name that is showed in router “android-e6d7d4cd358f67c4” or the name of device that is showed in settings.
Please help me.

1 Like

That name is not a dns or network name it’s just the name of the device sent to the DHCP server.
There’s nothing that can actually resolve it.

You need to use DHCP reservation so that the IP does not change or ensure that Zeroconf works correctly so that Yatse can automatically find the new IP when it change.

Or use a proper DNS server that register those devices.

In fact, i need to use my smartphone as a router of the wifi network where the devices with kodi and yatse are connected. Above I mention the router because it would be easier to test and verify the parameters.
The problem is that when you are using the smartphone as a hotspot is not possible to set static ip, because it changes the last two fields in a random way, for example, sometimes the ip is 192.168.173.29, another time 192.168.53.29 … therefore if i fix the ip devices, it is not possible to connect to wifi.
For this reason use the hostname of device would be the best solution, because it would avoid to change the hosts ip everytime.

But there’s no magic in network you know :slight_smile:

There need to be something that convert that name in an IP. That thing is usually DNS. If you can have a working dns capable of resolving that name then Yatse can’t.

The other solution as said is that your network properly support Zeroconf and Yatse will find the new IP with it.
Yatse also scan the network but it’s way slower and may not 100% succeed.

1 Like

I understand. I enabled the zeroconfig in all devices, but is not working, i need to change the ip adress manually. Do you have some material about configuration and use of zeroconfig in details?
Another thing, as i’m using the devices in a local network, the solution would be define the ip range, for example 192.168.0.10 - 192.168.0.100, do you know if there is some app or configuration to do that in the smartphone that used as a router?

There’s no much your network just needs to support multicast.

Please provide logs How to get debug information and open a proper issue os I can see more.