UPnP renderers not detected

I am setting-up a Rasperry Pi player and get unlocker for casting on it. I tried PiCorePlayer and Volumio, no one is detected as a network player by Yatse. Hi-FI cast from same android tablet detect them.
What can I do ?
Thanks in advance.

Provide the asked logs in the template you removed ? :slight_smile:

Sorry, I don’t understand. I didn’t removed anything.

When you create a topic the post already have content about what you need to provide :slight_smile: This is what you removed.

Anyway as I said please provide logs (Click the link and follow it)

OK, sorry.
My registration account is not setup on testing tablet. I had to send log manually.
Did you received ?


Yes I did, can you please clarify what this log contains in the test?

  • What player should be discovered
  • What is the IP of the rpi

I see many different UPnP devices with different issues but many working correctly too.

Player is PiCorePlayer - IP :

Only devices listed by Yatse are :
Internet box media player :
VSX-924 AV Amplifier :

That’s strange that IP does not seems to answer any SSDP message.

Does this device also run IPV6 and have ip fe80::86b5:41ff:fe6a:16ae ? Could be some problem with ipv4/ipv6 mapping somewhere. Can you try running Kodi on that device? (And BTW why not using Kodi there?)

Running PuTTY ssh session
ifconfig return only IPV4 address
IPV6 is activated on Internet Box router.
So I suppose IPV- is not activated on PiCorePlayer distribution
This IPV6 may have been cashed somewhere when runing the same hardware with another distribution.
This device is only for audio in my bedroom, so it’s a HiFiBerry compatible HiFi distribution.

Then I lack idea, maybe some filtering on the Wifi router, you can disable upnp relay on it.

But libreelec fully support hifiberry and will work a lot better than relying on shitty UPnP protocol.

Librelec is not so convenient to setup as a headless system and I am interested by LMS functions (Alarm clock and sleep mode, also testing Squeezebox for Kodi add-on) from PiCorePlayer. What do you mean by “shifty UPnP” does it mean you use another casting protocole ? I tried to activate Shairport, but it doesn’t help. “Shifty”, are you thinking time synchronisation and multiroom function ?

Shitty :slight_smile: As shit, bad protocol, one of the worst inventions actually with 95% of devices not respecting standard.

Libreelec is used as headless music player by a tons of users controlled via Yatse, so not sure why it would not be convenient. Yatse have sleep mode, and Kodi probably have addons for alarm clocks too.

You could also use OSMC as a more complete distro that embed Kodi and could have other things installed.

Oops ! I’am getting old, bad eyes :-(. I confused shifty and shitty.
I was mainly pointing the initial setup phase where you can’t help connecting to one display unlike PiCorePlayer or Volumio. I will consider the OSMC distro and or add-ons solution.

But you don’t answer about which protocole yaste casting use ?

Yatse use the protocol of the player, if you try to stream to upnp player it use upnp as no choice :wink:

Another for firetv another for chromecast another for Kodi another for firetv.