Unable to add Jellyfin host to Yatse (with Base URL)

Hi,
Could you please see below and advise? I accidentaly deleted my host when trying to resolve the same problem as reported in topic “Jellyfin and Plex both failing to transcode” and now I am unable to add it again.

Issue description:
Unable to add Jellyfin host to Yatse, process ends with a message “Unable to get server version (…)”. Jellyfin has BaseURL configured but it worked well with Yatse until I accidentaly removed the host. When it worked the value from BaseURL parameter of Jellyfin was set in advanced host settings in Yatse as subpath. When adding new Jellyfin host I do not see any field to put the subpath - as far as I remeber advanced host settings are available only after successfully adding host. I am able to access the server both locally and over internet with web browser or Jeyllyfin Android app.

Logs:

Screenshots:

Additional information:

Remove the base url and configure Yatse :slight_smile:

They have half added this without proper redirect or ways to get the url.

Oh, I see. Base URL implementation might have some problems but I had this configuration working until yesterday when I deleted the host.
Wouldn’t making the subpath field available in host wizzard solve my problem? When the base url was introduced in Jellyfin I simply edited host in Yatse and made sure that subpath matches base url and then it worked prefectly. I am pretty sure that I can make it work again by using the flow as described below but having the possibilty to set subpath in host wizzard seems better option to me:

  • clear Base URL in Jellyfin
  • add jellyfin host in Yatse
  • edit the host in Yatse and set subpath matching desired Base URL
  • add desired Base URL in Jellyfin

Not having this automatic means more complicated wizard means tons of more support.

They forced a base url on update this is a crazy move without the proper needed additions.

They do not answer on the issue I opened there. But I won’t add more support on my side for something that should not have happened.

I don’t even understand the need for the baseurl at Jellyfin side that should be handled via reverse proxy or other means when you actually want security.
They redirect from / to the url so this does not add security at all just break APi consumers.

Roger that. I will solve this on my end, one way or another. Thanks for quick responses :slight_smile:

You can still post there on my issue so that they expose the baseurl properly in the auto detection :wink:

And you can backup hosts and settings to file or cloud too.

Could you please provide a link to your issue? Can’t find it.