Two-way video position sync?

Is it possible to have two-way syncing between Plex or Jellyfin?

Currently it does not seem to work, if it does exist.

If you watch 5 minutes of a video on PC, Yatse has the position marker at 5 minutes.

If you then watch 5 minutes on Yatse (10 minutes total), and sync the library, the position marker changes from 10 minutes back to 5 minutes.

I am assuming this is because the new position does not sync to the server (Plex/Jellyfin).

Everything is synced in all direction, please give logs and more details.

Here’s the log:

debug.log (3.7 MB)

Recreation: (times are examples)

  1. I chose a show that already had a position saved at 2:04
  2. I skipped ahead to 5:00
  3. I exited the show (via MX Player)
  4. The resume position reflected the updated time (5:00)
  5. I refreshed the show view to sync the library
  6. The position reverted to 2:04

Hum there’s something strange on Plex side :frowning:

I send the correct command with the new time and it return the previous one.

I’ll need Plex logs to see what’s happening.

Here’s the logs from Troubleshoot > Download Logs:

Plex Media Server (5.3 MB)

For what it’s worth it does a similar thing on Jellyfin.
Instead of reverting to the prior time, though, it marks it as fully watched.

Well this is strange logs shows that it get all correctly.

I’ll have to redo more tests with latest Plex server version maybe they changed something again :frowning:

For Jellyfin they still have a fair share of issue inside their server part, but you can open another issue with logs related to that so I can look into it too.

Actually just updated Plex and impossible to reproduce.

During playback what does the Plex interface shows? Does it show Yatse playing and starting at proper point? Does it update the last played correctly and show it as first continue watching?

Do you have something special on your setup? Like multiple accounts and special permissions on that library?

During playback while I’m watching via MX Player the current episode does not show in Continue Watching - it is just under “On Deck.”

It shows under Continue Watching once I sync.

Nothing special, no.

It seemingly works fine now. I’m very unsure as to why it was not working earlier - I did not test with an entire new episode started via Yatse, but it worked fine after I tried that.

I tried to reproduce by getting to a state on an episode started by Plex, but syncing worked entirely fine that way too.

Not too sure how to reproduce the issue now.

I did do a server update last night, maybe the prior version had an issue?

Jellyfin issue does persist, I will get the logs in a little bit.

Yatse Log:

debug.log (5.4 MB)

It doesn’t seem like any logs are relevant logs are available on Jellyfin? (picture)

The latest log is attached for transcoding though, but as stated, I don’t think it’s relevant:

Log.omcsettings.txt (18.0 KB)

Ok so was able to reproduce, now when I stop transcoding session they mark the media as played …

I suppose they changed / broke something, I’ll try to find out what and workaround that.

1 Like

Jellyfin will be fixed for next release, for Plex I’ll need a repro thing if it happens again but was probably a bug on server part.

1 Like