Two Bugs with 10.5.5

Hi Tolriq,

I have encountered two bugs with the latest Play Store release which I would like to share. Actually I discovered the second due to the first. First one being more serious however since it is a bit annoying in day to day use. I’ll try to explain my setup briefly so you can have an overview:

  • Two Kodi Leia Pi’s, one’s the main media center and the other a secondary. Both share the same MySQL Database. The secondary Media Center is configured in Yatse Host settings to point to the main media centers database.

  • Two different Android Devices with different OS Versions (Nexus 5 and Pixel 4 XL)

Next I’ll describe the bugs:

  1. with the latest Yatse release one of the host vanishes at some point. And it’s always the first one (in my case the main host). The host is completely gone and instead the secondary is duplicated and takes place of the first entry. Now I have two copies of the secondary host while I cannot access the first one. I’ve tried first to delete all App Data and restart from scratch but I could reproduce this every time and on every android phone I own. I’ve noticed that I can almost reliably make this happen on purpose every time when I switch hosts from the side menu - most times it works/breaks by switching twice from some kodi host to local device and back. If not twice a few more attempts and it will break. After that my hosts are messed up.

  2. Due to my testing and deleting App Data I saw this bug too. I keep my Hosts/Setting/Custom Commands etc. in the Cloud via Yatse Menu. While restore is working fine for everything else, Custom Commands are not restored. Doesn’t matter how often I try to import them, they are never restored (and yes I’ve saved them before to the cloud). Seems this is broken somehow.

Since I know you need Screens/Logs I’ve tried to make this as clear as possible.


First Screenshot shows a fresh installation/restore, while second shows how it looks after the issue 1). For two i don’t have any Screenshot but I doubt it would be needed.

Additionally I tried to re-create the the issues for you to see it in the logs. I’ve seperated them for easier viewing. Please find the here:

Issue 1: https://pastebin.com/YfhvZ85G

Issue 2: https://pastebin.com/ZRSXAt99

I hope you could learn something from them. If something unclear plese let me know.
Thanks!

First log is strange as missing stuff but I have a lead.
What host is declared as the master ? (So the one that does not have the shared db setting)

Second log does not seems to show any restore attempt. Did you try to restore?

Hi,

Yeah, I created both logs and immediately reproduced each issue and then stopped the log.

To your questions: The master in my use case is the one with the ID 2 from my first screenshot. IP address ending with .21. This one gets overwritten as you can see in the 2nd screen.

About the 2nd log. Very strange, as I said I tried the restore and then stopped the log. I can however do that again if you lole, maybe even try it more than once so it would produce more output.

Ok so yes issue 1 will be fixed.

For 2 I need new logs yes please.

1 Like

Hi,

thanks, sound great. Will wait for the update to drop, to set everything up again and use it (plus confirm here) :slight_smile:

Sure. I deleted App data and made another log, this time by entering the Cloud Save Settings, importing “Custom Commands” back to the Remote, and then redo it again so it would produce more logs. Just to be clear, this is just not working for Custom Commands, if I import them via Cloud my right default sidebar stays empty not having restored my set up commands.

New Log: https://pastebin.com/EVj0zNqv

Thanks for taking care of it so far :slight_smile: Have a nice evening.

Hum.

Logs says:
CloudSave: Saved Game custom commands successfully imported

So the issue was more probably something that happened during the save :frowning:

Not sure we’ll ever know, maybe you can try to export some again and provide logs if you can’t import them too?

Yeah sorry, should have mentioned that. The little pop up message also says successful but actually nothing is restored.

You might be right with the save. I have some Custom Commands on my other phone in yatse. What im going to do is to cloud export them and try to import them on my other phone. I’ll create logs for both or see if it works.
I’ll edit this post or double post with new logs/Infos.

@Tolriq: Please disregard Nr.2. I did this again from scratch like I said and somehow its working now. Looks you were right, somehow the initial save was faulty. This leaves only 1) which I think you already figured out :slight_smile:

Hello,

I just updated Yatse to 10.5.5 and now I’m faced with the same issue as described in #1 here.
The Thread is marked as solved, so Im wondering if the fix is already rolled out??

thanks in advance,

hannes;

Hi,
unfortunately not as far as I can tell, I’m also waiting for a fix to roll out to use Yatse again correctly.

Greetings

Do you also use a shared master database ? If not then I’ll need a new issue and logs.

About the fix it is pushed in the current beta that is not yet in prod.

Hello,

thanks for your quick answer. Yes, shared database and exactly same issue as OP said.

I’m going to check for beta version, I guess it’s available via PlayStore Betaprogram!?

BTW thank you very much for all your work and this great app. I’m using it since 2012/2013 (can it be?) Pro Version user since the second week of using and donation abo since quite a while. Keep up your great work!

Yes beta on Play Store and yes Yatse is on Play Store since early 2012 :slight_smile: and before on Kodi forums.

1 Like

Thanks for the info, I checked a few days ago for a beta version but wasn’t online then I guess. Will install and test it.

Of course I agree with what Hannes said, thank you. Hoping Yatse will be around for a long time to go. After all it is one of the most polished and best supported apps on there.

@Tolriq: A quick check with the Beta 10.6.0B2 reveals the same problem with the double hosts. Actually it works once to switch but then its doubled. Maybe @hannes can also check. I can grab some fresh logs tomorrow.

Will need new logs yes.

Hello,

unfortunately I need to confirm, that the issue still appears in Beta Version 10.6.0B2

I’ll try to roll back to an older version for now…

I’m not sure, I can help out with log files, sorry.

hannes;

@Tolriq: New logs generated and sent to you via PM. Hope there is something on it, but Bug was definitely reproduced while Debug Mode was running.

Can you please describe exactly the steps you made to reproduce?
And did you connect to both host at least once before the issue occurred?

Hi @Tolriq,

I’ve also tried to include that in the PM but I will write it down again here in a bit more detail:

Beforehand: Yatse was uninstalled

Steps:

  1. Get newest Beta from the Store
  2. Open and quick restore settings & hosts via Cloud
  3. first start I’m connected to my main kodi Mediacenter serving as master, let’s call it ‘A’
  4. Open left sidebar and Switch from ‘A’ to ‘B’ (which has in Yatse settings to use ‘A’ database)
  5. Switch back from ‘B’ to ‘A’ -> Bug happens and ‘B’ is duplicated whilst ‘A’ is gone completely

So if I understand your question correctly then yes, connected to both at least once as per the steps outlined. Is that understandable somehow?

Can you try to skip the restore host and settings and start fresh to see if your backup contains strange data that generate this ?

I’ll try again to reproduce, if I can’t I’ll send you an APK with more logs.

Yeah, I can certainly try that. Only problem I could see with this is if the bug is caused due to some setting/combination of weird settings it might work with a clean setup but its hard to tell if it is a bug caused by settings or the cloud backup itself.
But lets see first.

Edit:
@Tolriq: Happens also with a completely clean setup. What I did:

  1. Start Yatse and add first host (master)
  2. add second host via assistant in yatse
  3. set setting of second host to “use master database” of first host
  4. switch from first to second host and back in left sidebar
  5. 2nd host is doubled

So its not related to my settings backup.