TV Shows not showing up when filtering by Source Library

Issue description: I have separate libraries for regular TV and 4k tv. My 4k library is very small (2 shows), but when I try to filter by source library, nothing shows up. If I don’t do any filtering, I can see that the TV show exists. In fact, I can see 2 entries for each episode, since I have each of those shows downloaded in both HD and 4K. This only happens for TV shows. I have a similar setup for movies, and filtering by the movies 4k seems to work just fine.

Logs: Provided Yatse Android logs. The only thing I did was turn on logging, go back to “TV Shows” and then swiped down to refresh the database. This generated quite a large debug file, sorry about that. I believe it contains a lot of library specific information. [deleted attachment]


Additional information: If I use the kodi web interface (Chorus), I can see each of my individual libraries listed there. Clicking on the Tv4k library correctly lists my 2 shows and individual episodes.

The logs does not show the full sync or the reproduction of the issue to know the values Yatse have for the sources :slight_smile:

And Chorus does not do source filtering on library mode, you can do file browsing in Yatse exactly as Chorus from file mode and you’ll have the exact same result.

Ah good to know. What would be the best way to get the logs to show the issue at hand?

As said full sync + repro :slight_smile:

So enable source filter then remove it :wink:

[deleted attachment, case solved]

Hopefully this shows it!

This is still not a complete sync, there’s no episodes sync in that, so no path to see what your Kodi returns wrong.

Ugh, what can I do to force a full sync?

You need to let the sync finish that’s all you stop the logs way before it’s ended. (No more rotating sync item in left menu)

Ok maybe the third time’s a charm :wink:

[deleted attachment] - case solved

Yes it is.

So you are facing Kodi limitations and there’s not much I can do, you have the same shows in those 2 libraries, so for Kodi they are only one so only return 1 path that is the non 4K.

Yatse have no way to know the other path and match to other libraries, unfortunately there’s no official support for sources filtering and proper management on Kodi API, this is all based on hacks, and you reach the limitations of those.

If those shows are only in 4K, then you need to remove all related data from library then ensure hide empty show is not enabled in Kodi then clean data and remove the show then add the show back only in the new folder, hoping Kodi have not kept some references somewhere.

Ahh I figured it might be something like this…

Do you think it’s ever in the cards to allow Yatse to access a database directly to pull information from? I know that is probably a ton of work, but it would be an awesome feature!

No way this would happens sorry :slight_smile:

As a developer myself, I completely understand. It would be a monumental task. Just thought I’d throw this out there.

Just to add, I found a way to have this work for now, though it requires some manual intervention.

First, I had to remove the show from my library in Kodi.
Next, edit the main tv show nfo file, and change the title to something different (I just appended - 4K to the show title).
In your 4k source in kodi, have the scraper set to local information only.
Clean your video library.
Update your video library.

I use Tiny Media Manager to generate the NFO files and other information since we can’t rely on TVDB or anything.