Trying to play audio file from local storage crashes Kodi (libreelec on arm)

Issue description:
When starting audio file from local storage that is not in library, Kodi always crashes/restarts.

Open Yatse.
Select Files from menu.
Select Audio Files.
Select local Music folder (ie. folder on the device Kodi is running on).
Select any file.

Result?
It starts to play but after about 1 minute or so Kodi crashes and restarts.
It happens every time. At least for me.

When I start music using Kore (official kodi remote) then it does not crash.
When start music using webinterface, it does not crash.
But starting with Yatse results a crash every time.

Logs:
Kodi logs can be found from here: https://tmkk.ee/kodi/

kodi-yatse, crash after about 1 minute (log from latest try - tried it 4 times in a row, crashed every time at about 1 minute mark)
kodi-kore, left to play for 3 minutes, no problems

Additional information:
Not sure what Yatse does differently but I just can not start any local audio file (ie. not in library and on local storage) from Yatse, it always crashes.

Running at the moment Libreelec 8.2.3.1 / Kodi 17.6 on different arm boxes (a95x/t95n/x96 mini/… mostly s905x CPU, 1-2GB RAM, different SD cards as storage). I have many arm boxes and also Raspberry Pi and similar products.
This problem has been around for a long time (years). I have upgraded Libreelec/Kodi several times in the mean time with no change.

Yatse version is 9.4.5/11068-arm64-v8a at the moment. But all older (at least last few years) version had the same problem.

Not sure if it happens on x86 hardware also. I do not run Kodi on x86 hardware.

Let me know if I can provide any more information.
I am also happy to try out experimental versions.

I have also purchased yatse unlocker. But at the moment I am running my Android remotes without any google services installed, so unlocker does not work (no google account to link to).
It would be nice to get Yatse paid version to work on devices without google. But that is something for another thread.

Yatse use Kodi public API, if Kodi crash there’s Kodi bugs that they need to fix :slight_smile:

But you are lucky this is about music so you can report to Kodi forums in music part with the crash dumps and Dave should not ignore them just because it talks about Yatse.
Unfortunately they won’t care about Kodi 17 so you’ll need to reproduce with last Kodi 18 and probably Kodi 19.

In all cases never heard about such kind of issues, Kodi have many flaws and bugs but delayed crash never seen that. So it’s probably something quite specific.

What I am saying is Yatse does something differently.
Kore does no make Kodi crash.
WebInterface does not make Kodi crash.

But starting the same file with Yatse makes it crash every time.

It also happened with Kodi 16. I have not yet tried 18.

I know Kodi 17 is old now.
I just have to wait until I can upgrade all of my devices to Kodi 18 at the same time. This is the limitation of using MySQL database for library so it is one library for all of my devices.
Last time I checked there was not stable Kodi 18 image for all of my arm devices - I will check again in few days.

Yatse does many things differently to fully embrace what Kodi offers.

That does not change the fact that JSON RPC is a public API with a well defined behaviour, if using an API makes Kodi crash it’s Kodi issue not the API consumer as I can assure you that I properly use the API since I helped a lot in their conception / implementations.

Everything that Yatse does is for a reason and most of the time to workaround Kodi issues, so what make you crash (And as said never heard of such kind of delayed crash) probably solves issues for thousands other users, there’s not much I’ll be able to do on Yatse side to prevent a crash only you seems to have that could potentially private all the others from better functions.

And if you can reproduce the issue easily then you can start with a local Kodi installation and see if the issue is present or it’s one of the many Mysql implementation issues.

Ok. Thank you.
I’ll dig deeper and see what I can find.
Maybe I try Kodi support also.

I posted it here because I thought it was something that Yatse does.

It can be caused by Yatse using different API end points, but it’s still a Kodi crash caused by a Kodi bug that must be fixed at Kodi side since it’s all public official end points.

If you post in music forum with a recent Kodi I’m pretty sure Dave will have a look. But if you can have a simple reproduction on a Kodi 19 it’s better for sure.