TouchPad remote very unreliable


#1

Be sure to read https://yatse.tv/wiki/debug-yatse-kodi-remote to provide necessary logs and information.

Issue description:
Nice app but there are some issues with the TouchPad remote.

When swiping and then tapping fast, it will not register that tap. Tapping slower after swipe works but not an ideal solution

The fast repeat mode doesn’t work good. Sometimes it works, sometimes it won’t. Pretty random unfortunately

The long tap should be registered before key up. Right now you can hold your finger 10 mins on the display but it will just register it when you lift your finger up

Logs:

Screenshots:

Additional information:


#2

Well thanks for ignoring the logs :slight_smile:

Long tap can’t really register before key up because of fast repeat mode.

Fast repeat that you probably have no fully understood, the repeat speed and direction are relative to the distance and position between current and first touch.

Unfortunately you do not really give much details about your issues to tell more.


#3

Sorry about the logs. Thought the issues are pretty much generic and can be reproduced.

Well I think if finger hasn’t moved away from first tap location for duration x, you could register longtap?

About fast repeat mode: yeah I thought that but it’s still unreliable (for me). Like I start the tap at the bottom of TouchPad, then swipe up, it will start fast repeat at little more than 50% but when holding finger at that position or moving further up, it will switch back to regular speed

Checked the logs now but there’s not really anything about the TouchPad. Just a few of the following lines but guess that won’t help

22:51:29.935 Verbose/EventClient: [email protected]: sendButton(R1,up)


#4

Logs would show what happens and your issues, so please upload them.

Nothing you say is easy to reproduce, the gesture pad is loved by users since 5 years and no one ever reported any issues :wink: (And I use that feature a lot myself too)

All your descriptions looks really more than a touch problem on your device/OS registering bad events at some points.


#5

Yeah inserted logs now in the post. Is that enough or do you need something else?

Full log

209-01-09 22:51:29.095 Verbose/EventClient: [email protected]: sendButton(R1,up)
2019-01-09 22:51:29.097 Verbose/EventClient: [email protected]: Sending ping
2019-01-09 22:51:29.361 Verbose/EventClient: [email protected]: sendButton(R1,up)
2019-01-09 22:51:29.439 Verbose/EventClient: [email protected]: sendButton(R1,up)
2019-01-09 22:51:29.514 Verbose/EventClient: [email protected]: sendButton(R1,up)
2019-01-09 22:51:29.591 Verbose/EventClient: [email protected]: sendButton(R1,up)
2019-01-09 22:51:29.935 Verbose/EventClient: [email protected]: sendButton(R1,up)
2019-01-09 22:51:30.251 Verbose/EventClient: [email protected]: sendButton(R1,up)
2019-01-09 22:51:30.561 Verbose/EventClient: [email protected]: sendButton(R1,up)
2019-01-09 22:51:30.868 Verbose/EventClient: [email protected]: sendButton(R1,up)


#6

I need full logs untouched, theres 0 information about your device / OS here.


#7

OnePlus 6t latest oxygen os android pie.

So it seems that when I hold my finger at a particular position, it keeps fast repeat but when I move my finger further up, it will fall back to regular speed? When I move my finger down again then to that spot, it goes fast


#8

It should not it should keep from first position, if you move further up it should increase speed up to max one.

Please upload the full logs as asked … latest means nothing, no Yatse version …


#9

OnePlus6T/OnePlus6T/28/9/ONEPLUS A6013/OnePlus/0/false/-2/-3
2019-01-09 22:51:26.672 Verbose/YatseApplication: [email protected]: initialize: 8.8.3 (10722[arm64-v8a,armeabi-v7a,armeabi]) false


#10

I just tried on an old galaxy s4 mini and no issue there but due to the screen size the dimensions of the TouchPad are a lot smaller so maybe it’s related to that?


#11

If you had uploaded full logs I could answer with more ease :slight_smile: But it seems giving them is like removing your teeth :stuck_out_tongue:

Anyway I now have a little more information still missing the layout you use :wink: but I guess you want to keep your teeth :stuck_out_tongue:

Will try to reproduce in emulators with same config.


#12

Tried in landscape orientation now on the OnePlus and it’s also working a lot better (TouchPad also much smaller now)


#13

I’m using alternative 1. Tried standard now and it’s much better too so guess there’s an issue with the big pad

What about the other 2 issues. You think there’s some kind of improvement possible. Apart from that really great app.


#14

Oh sorry I got it wrong. I was using standard apparently and got these issues but less issues with alternative 1


#15

Finally fully rewrote the component to fix all the issues + add nice indicator for the repeat mode.

Please join beta on Play Store to report back when next beta start.


#16

That’s good to hear. Is there any eta for next beta?


#17

I never give ETA but hopefully soon.


#18

Beta is up :wink: Please report about the indicator style.


#19

Working perfect now man. What an improvement in contrast to what it was before. Also it seems like if reacts faster now. I always found it a little slow compared to the ios app which I’ve been using for years but now they’re equally fast.

The indicator is a little weird because it’s new but I don’t mind it :blush:


#20

Oh and there’s one more thing. I use yatse like only to control kodi. Not having any items in the library at all apart from pvr.

When I click the playing notification it’ll open yatse but with the big player view uncollapsed and the remote behind it so I’ll always have to swipe it down before I can to the remote.

Maybe if you find some time and consider it useful you could make it an option to show the player view or not :blush: