Switched apartment units and Yatse isn't working now

Hi all,

I’ve been using Kodi and Yatse for over a decade and never had an issue I couldn’t figure out but I’m banging my head on this one…

I live in a university apartment and it provides Wi-Fi and Ethernet Internet. I have had an Xbox Series X since March and had no issues getting it to work with Kodi and Yatse, the Xbox connected via Ethernet and my phones (OnePlus 5 and 8T) connected via Wi-Fi and working flawlessly. I can even walk around the building, connecting to various other routers in other apartments along the way and still control Kodi, which is pretty amazing.

However, I just switched to another apartment unit one floor down, connecting the same ways and without having to make any adjustments to my phone or Xbox to be connected to the internet, and made sure to update and triple check my IP address in Yatse to the correct one in Kodi, but it just won’t connect for several days now.

This is what’s making me super confused…the official Xbox app works on both phones and I can control my Xbox with it no problem but Yatse just won’t connect or control Kodi…

If both Yatse and the Xbox app didn’t work it would make more sense but I can’t figure out why one does but not the other, especially since Yatse was always more reliable in this regard. I tried rebooting my phones and Xbox, clearing Yatse cache, creating a new host, disconnecting and reconnecting Ethernet, toggling Wi-Fi off and on, etc, but to no avail.

Any ideas? Thanks!

Well why not start by providing the mandatory logs that the template you deleted ? :slight_smile:

1 Like

Thanks! I just didn’t think logs would be necessary since everything worked previously and the only thing that changed was the IP and thought it was more of an issue that couldn’t really be reproduced and maybe just figured out based on the circumstances.

That said I generated a log of me trying to add the new host with the IP and ports but it failing and I included images of system info and services just in case that helps.

Oh and I didn’t delete anything I just left the old host alone and made a new one, but neither work.

Thanks again!

HTTP FAILED: java.net.SocketTimeoutException: failed to connect to / (port 8080) from / (port 47032) after 5000ms

The IP range does not match so it’s probably Kodi showing the wrong IP as it often do. Find the real IP from the Xbox interface.

1 Like

Thanks. Unfortunately I tried that and Xbox shows the exact same IP address.

Well I don’t know but try to open that IP and port in chrome on your phone and it won’t work either.

There’s something wrong somewhere.

1 Like

Ok weird, and yes it didn’t open but just timed out. I just don’t understand why it was fine in the other unit with the same Internet connections and why the Xbox app is able to connect, so it can’t be a FW issue based on both of those things otherwise why would it work previously and why would the Xbox app continue to work?

Ask the network admin there :slight_smile: But as soon at it will work on Chrome it will work in Yatse.

1 Like

Sadly there is no network admin here, they are just using Suddenlink and some third party company for the actual network within the building.

The first time I connected the Xbox to the Internet via Ethernet it made me enter my authentication in a separate page and I connected to the Internet and Yatse and Kodi were up and running flawlessly for months. But when I moved to the new unit it was just instantly connected to the Internet after plugging in. I wonder if there’s a way to reset the Ethernet connection so I have to log in again and if that would help?

Also, I switched the Xbox to Wi-Fi and was able to get Yatse to connect that way but it’s really weird it worked with Xbox on Ethernet before but only Wi-Fi now. For obvious reasons I’d much rather use the Xbox on Ethernet though :[

I have no way to know sorry, this is network issues specific to your place.