Subtitles problems in kodi options

I have a raspberry (OSMC) with:
-kodi with DLNA activated (all options)
-jellyfin with DLNA activated

I bought yatse y bumblebeUPNP.

I have problem with the subtitles (srt) in yastse. If I try to do this, with the same movie:

KODI (UPNP) -> yaste (srt detected in the menu - > sent (local)-> player mX -> I cant see any subtitles

However:
JELLYFIN (UPNP) -> yaste (srt detected in the menu - > sent (local) > player mX -> I have subtitles
KODI (UPNP) -> bublebee (local)-> player mX -> I have subtitles
KODI (UPNP) -> TV LG -> I have subtitles

I hope you can undestand my “diagrams”.

Any idea?

Thanks anyway. I think your program it’s amazing.

No logs no chocolate :slight_smile:

But Kodi via UPnP from Yatse with external subtitles can’t work as I can’t resolve properly the files. You need to use Kodi directly, so don’t activate the force UPnP option.

Hi, im not sure what option is. I tried enabling and disabling “forzar upnp para emisiones” without sucess.
I attach the debug file this time

debug-20200321_155057.zip (6.8 KB)

Well according to logs subtitles are found and transmitted to Mx Player.

Subtitle found: inglés (eng) - https://REMOVED:[email protected]:8080/vfs/%2Fhome%2Fosmc%2FPeliculas%2FHamlet%20(1996)%2FHamlet.1996.1080p.BluRay.x264-[YTS.AM].en.srt
Starting external video player with intent: Intent { act=android.intent.action.VIEW dat=http://192.168.1.21:57645/… typ=video/* flg=0x1 pkg=com.mxtech.videoplayer.pro cmp=com.mxtech.videoplayer.pro/com.mxtech.videoplayer.ActivityScreen (has extras) } - Bundle[{video_list=[Landroid.net.Uri;@f197956, video_list_is_explicit=true, subs=[Landroid.net.Uri;@f550dd7, title=Hamlet, position=1, secure_uri=true, return_result=true}]

Are you sure the subtitles are not visible in Mx Player? Click the sub button in Mx Player and enable them?

Yes, i am.
subtitles/pannel is empty of srt.

The same video with jellyfin as server, i have subtitles (stream.srt i. Subtitles/pannel)

Then try to disable BubbleUpnp in settings or enable all codecs for local device in settings.
Maybe Mx Player does not allow subs from different urls.

Hi,
I tried both without sucess.

I think its not a problem about mx player. I tried with my TV LG:

  • with jellyfin as server subtitles works
  • with kodi fails
    Pd. I did the test with with my tablet ( Galaxy)and my phone (Xiaomi).

Any idea?

TV is normal as you have a password and UPNP does not support that so switch to Kodi UPnP and no subs :frowning:

Try VLC as local player and test without Bubble as requested with new logs …

Hi,
I did some test and now i get It working.

Problem was that i have ssl activated in kodi. Disabled, i have subtitles in mplayer mx (not un vlc).

I dont know If It can be fixed.

It’s probably your certificate that is self signed or invalid :frowning: Nothing I can really do about that :frowning:

No, my certificate is valid (by letsencript).

Its not problem, I disabled It.

it’s probalby valid for a domain not an ip and you connect via IP :slight_smile: SSL is complex to have working on Kodi.