Subtitles are burned in when downloading from Plex (cannot disable)

Be sure to read How to get debug information and open a proper issue to provide necessary logs and information.

Issue description: When downloading TV shows from Plex (changing offline state, not smart sync) it downloads it fine and streams to MX Player but seems to burn in subtitles, I’ve tried downloading both 720p and original quality the issue persists on both, the subtitle option shows “English (SRT)” but I cannot change it, it’s greyed out or sometimes it lets me select it but shows “English (SRT)” twice.

I wiped the data/cache for Yatse and it temporarily solved my issue again but it seems something triggers it to download and burn in the subtitles and I then cannot turn it off. Just to clarify, I do not want subtitles at all but have so much media which has SRT files in Plex deleting them isn’t an option.

Logs: https://lolcatho.st/cat/meow-1pd.zip

Screenshots: Video plays in any player with subtitles, they are burned in.

Additional information: If you need any further details or logs please let me know.

Yatse does not burn anything.

It does download the media and it’s associated external subtitles and send them to Mx player accordingly.

If Mx Player does select a sub by default and prevent unselecting it, you need to see with Mx Player support what is happening.

Try with VLC to see if they handle things properly.