Streaming problem with Essential PH-1

streaming
#1

Hello all!

I really have a strange issue with Yatse and need your help.

I have a Raspberry Pi 3 set up as Kodi media server with a attached HDD as NAS. This worked perfectly fine. Now i have a streaming issue but only on my Essential Phone!

When I use Yatse and try to stream locally to my phone the video starts immediately and buffers around 1 Minute of the video. Then the video plays but it will never restart to buffer until it gets stuck. If i manually move a few seconds forward the buffering starts again.

I’m using MX Player. The funny thing is when i use MX-Player without Yatse the video plays perfectly fine till the end without buffering issues.

I can even watch this on my fritz.box WiFi protocol. When I use Yaste a high peak in bandwith appears at the start of the video and suddenly it goes to 0. If I use the MX-Player or VLC without Yatse I get an inital high peak and then a steady low data transfer rate.

Even on my old Nexus 7 the Yatse stream works like a charm.

Has anyone experienced this issue? I played along with all network settings and even reinstalled Kodi on my Rasperry Pi and reinstalled Yatse on my phone. But nothing changed.

Thanks for your help and have a nice day!

0 Likes

#2

As soon as the video is started Yatse is not involved at all.

Yatse does resolve things and add necessary parameters but only give the player a Kodi url, so all streaming, buffering and everything is fully between Kodi and the player.

You can activate the advanced settings Force UPnP so that Yatse find another url on Kodi that use a different web server that can fix such kind of issues.

0 Likes

#3

Thanks for the fast reply. I tried it but it didn’t resolve the problem.

I don’t get it why the problem only appears if I use Yatse and only on my Phone. Tablet works fine like I said.

Do you have any other Ideas?

Greetings

0 Likes

#4

Well how do you play the video when not using Yatse?

Provide Yatse logs:

And I’ll give you the link to play the media from Kodi, then you’ll open it directly in Mx Player / VLC and will see that you have the same issue.

If not then your phone is doing something very special when starting an app from another app but I have no idea what and there’s nothing I can do about it since well as soon as the other app is started Yatse is unused.

0 Likes

#5

In this .png you can see the start of the stream, then it buffers and at the right end of the picture the video stopped but there was no further buffering.

I sent you the Debug log file via Yatse.

If i’m not using Yatse i open the media file via a file explorer (ES Datei Explorer/Total commander) and press play with MX-Player. And this worked without issues. But this should be exactly the same as yatse telling MX-Player to stream the video right?

Greetings

0 Likes

#6

Not at all :slight_smile:

Yatse talks to Kodi and it’s Kodi that serve the file, Yatse have no access to the root file.

Try to open the url in Mx Player / VLC directly and you should see the same issue.

0 Likes

#7

Yes problem is still there. But i don’t understand why. Opening through Total commander works fine.

Nevertheless. Could you please delete the link? I’m not happy with erveryone seeing my folder structure.

Cheers

0 Likes

#8

99% of Kodi users have such structure :wink:

And as I try to explain this is an issue between your phone and Kodi, Mx Player talks to Kodi and have an issue it’s not related to Yatse.

You have mounted something on your rpi to /share Yatse have no way to know what where and how that point to access the files directly. So only Kodi can serve the files since only Kodi have access to the files.

Now it seems essential phone have plenty of wifi issues, maybe you can find more clues on Google. Or try another rpi build like librelelec that is well often better than OSMC as more dedicated.

0 Likes

#9

I know that there is an issue with my phone. But i don’t get it why it only appears when i open the files through Yatse or the link you gave me earlier. Somehow MX-Player forgets that there is an active stream.

Google is not my friend in this case. Tried it the last days and unfortunately the Essential phone is not that common so I couldn’t find answers in other forums.

Maybe I’ll try to set up libreelec on my other SD card.

Cheers

0 Likes

#10

I have just explained you twice :slight_smile:

Let’s try again.

Yatse or link gives Mx-Player —> Kodi —> File
Es Explorer gives Mx-Player -> Es Explorer —> File

—> = network
-> direct as on same device.

So in one case the file goes twice on network if your rpi is on wifi then maybe the rpi can’t handle so high traffic and your tablet triggers less (Wifi N vs Wifi b/g?)

If not then it might just be one of the many Kodi things that sometimes does not work for unknown reasons :wink:

To rule out OS issues, using stable libreelec is a great test, using the latest Milhouse build on Kodi 18 is the second test to see if Kodi have improved things too :wink:

0 Likes

#11

Thank you again for the increidble fast reply. I so Unserstand the ways how the devices communicate Wirth each other. Bitte i don’t Unserstand why the issue only appears under certain conditions.

Meanwhile i installed KODi in my Phone and used the my NAS shared folder as source for this and no streaming issues at all.

Regarding WiFi Speed: If i try copying a File i get constant 15-16 MB/s to my PC. So that shouldn’t bei a Problem.

I’ll try playing around again in the evening. Maybe i’ll detect the cause of the Problem

Greetings

0 Likes