Stream to phone cannot find file


#1

Hello,

I have just installed Kodi Leia via my QNAP. Yatse worked fine before that, now when I play any file, it says The Location Cannot Be Played. I noticed the error has /vfs// in the path, but this was not a path I defined in the yatse setup (the set-up doesnt give you this option, but all the media shows fine through the scan). I cannot remove the double //

Log: https://drive.google.com/file/d/1NNP9mlAInrEcq0aUYwGZPZBY67Pkwf0m/view?usp=sharing

Screenshot: https://drive.google.com/file/d/135mQ9ReRMatUMhUnye72m7-FFcFzc4O5/view?usp=sharing

I appreciate any help with this. (Sorry of this is a kodi issue rather than a Yatse one)


#2

You forget Kodi logs, but the issue is on Kodi side, probably wrongly defined sources or the Qnap package have faulty http server.


#3

Thank you for the help. Not at my Pc at the moment, so I might be back.

I was wondering if it was a Kodi issue, but everything is working fine on Kodi and Yatse was able to scan all the media (just not play).

the source on Kodi is just using Root FileSystem, as all media is local on the qnap. I’ll have to check if there are any permission issues.

I’ll have to take another look when I get home. Thanks again


#4

Kodi internals and what they exposed are 2 very different things with tons of different bugs :wink:

[630] HEAD http://192.168.1.3:8189/vfs/%2Fshare%2FPublic%2FMovies%2FGreen%20Book%20(2018)%2FGreen%20Book%20(2018).mkv
[630] HTTP FAILED: java.io.IOException: unexpected end of stream on Connection{192.168.1.3:8189, proxy=DIRECT hostAddress=/192.168.1.3:8189 cipherSuite=none protocol=http/1.1}

Your Kodi does not properly answer on a simple HEAD query, it’s internal to Kodi.


#5

Thank you for your great help, despite it not being an issue with your product.

I will mark this as closed and go to the proper channels.

Thanks again for giving the help you have.


#6

Do not hesitate to come back and give solution for other users to know :slight_smile:


#7

Have the same issue here, this seems to affect everything related to UPnP/DLNA streaming, not just Yatse. The same issue also applies when using the built in web service in Kodi. Posted a thread about it on Kodi forum (https://forum.kodi.tv/showthread.php?tid=342193). So far, no solution that I know of.


#8

I never found a solution either. Instead, I just added the media to Kodi using SMB rather than the root file system. Since doing that, it has worked okay - but not really a ‘fix’.


#9

As you said, it’s not a fix. I have my files localy on the same computer running Kodi, so it’s not a really a workable solution unless I set up a server with the media itself (planing of it in the future thou). I read something about the vfs-sftp plugin. But I don’t think it has anything to do with the UPnP/DLNA feature at all. Think it’s more about setting up a mount point within Kodi.


#10

I found the solution after some digging and trying to find out how VFS (Virtual Filesystem) in Kodi worked. You have to add the path to Kodi’s VFS that UPnP/DLNA tries to access. When I looked at the path it started with /home/kodi (http://kodi:8080/vfs/home/kodi/…), which is my home folder.

To add that path (in my case the root folder), I had to go to the file manager and add the root folder as a new source. After that, I could reach the files I tried to stream. What folder to add depends on your system, look at the URL you get from the built in web server when trying to stream a video.


#11

@zynex this is exactly what the FAQ explains actually :wink: Your issue is different from him that have an issue specific to Qnap.

That’s why you should always open your own issues with logs since issues are often not the same :wink:


#12

Ah, my bad. Didn’t read the FAQ actually :slightly_smiling_face: Sounded like we had the same basic issue, maybe misinterpreted the issue he had :slightly_smiling_face: