Stream to Chromecast (Google Home) Issue

Hey there!
I’m using Yatse since some days and I really like the app in design, funcionality and the most it’s streaming function, since i use it i got rid of kore.
I have three Raspberry Pi3’s running libreelc (kodi) for my bedroom, livingroom and an optional Rpi3 as a “streamingstation” configured especially for yatse.
The Yatse Remote- and library-functions are working great, I can control all of my media-centers and also my network (LAN) is running great and pretty stable.

I Use Yatse on three different android devices:
Tablet (Android 5.x)
Tablet (Android 7.x)
Smartphone (Android 7.x).
In general, it works good with all of them.

The only issue that i have is when it comes to stream/casting from kodi via Yatse to my 5 Google Home devices (speaker). It connects,- you can hear the “ping” (connecting sound) and i can start streaming/casting like one or two, maybe three files. But when i stop/pause/abort the cast, i can’t go back and i have to restart the Rpi3 to continue streaming/casting.
It say’s something like

“Media not found / Problems finding the UPNP Server / Is the UPNP in Kodi activated? Share UPNP libraries”
“Does this Player supports the media type?”

I’m running 2 Rpi’s with Libreelec Kodi 17.3 and one with 18.0 alpha.
The media is stored on an network attached storage (NAS)
In Addition: The Google Home Group is running fine. I can stream my Android Player (PowerAmp e.g.) pretty good and without any problems.

EDIT: Off course all my UPNP/DLNA settings are set and librarysharing is activated
EDIT2: The issue appears with all devices in any combination. I reinstalled the app, libreelec, kodi, restarted router, nas and all devices included in this thing. :weary:

Maybe there’s a workaround?
Greetings from Germany!

As always :slight_smile: Logs logs and logs.

If restarting the rpi is the solution then the bug is on rpi and Kodi stop answering on UPnP, or your router have UPnP proxy and bugs at some point.

The problem is that Chromecast does not support password protected content, so Yatse must use Kodi UPnP to access the media. You can remove your Kodi password and test, if it works better then UPnP issue somewhere to be found.

Thank you very much for the fast reply. I will test that.
I’m sorry i havent submitted the logs yet, I’m going to try that workaround (no password) and tell you later!
Best regards!

Hey @Tolriq ,
Actually I havent done anything and it work’s since my last post. I haven’t removed the login on Kodi and on my NAS, however i’m satisfied.
Regards from Germany :cowboy_hat_face: