Sporadically missing Language Selection in Now playing Screen

Hi,

lately I have a minor problem with Yatse. I cannot figure out if this is a bug or intended behaviour, however I cannot remember that this happened in the past so I assume the former.

Problem: In the Now Playing Screen in Yatse when starting a media the Language Track Selection Button (Audio Language and to set delay etc.) is missing sporadically. By missing I mean not showing at all. I noticed that in order to get it to show up again I simply have to reload/get Yatse out of focus (e.g. pressing back to go to the Homescreen) and to enter Yatse again.

Please see the following Screens for a better understanding:


First Screenshot shows the Now Playing Screen right after starting/continuing the movie, while the second screenshot shows how it should be, i.e. to show the Track Selection Button. For this to work again I simply closed/reloaded Yatse and opened it again, the workaround mentioned above.

What I found out: I can almost always (like 8 out of 10 times) reproduce this problem. It seems that it is triggered if Yatse is loaded “fresh” and not out of memory. I can trigger this behavior by manually “Force stopping” Yatse in the Android Settings. When doing so the Track Selection Button is almost guaranteed to be missing when beginning the next play of a movie/show. So to reproduce, what works for me:

  1. Open App Settings for Yatse (Android Settings Menu)
  2. Force stop Yatse
  3. Open Yatse
  4. Play something
  5. Go immediatelly to the Now playing Screen, the Button should be missing until you “reload” Yatse

Please let me know if something is unclear. Thanks!

Details:
Yatse 10.6.6a
Pixel 4 XL with Android 11
Kodi/Libreelec Leia, latest release
Debug: 2021-02-07 15:10:26.324 Verbose/MainInstance: initialize: coral/coral/30/11/Pixe - Pastebin.com

Thanks for detailed answer. What is latest release for Kodi there’s quite a few different builds and versions :slight_smile:

Please show info screen from Kodi or Kodi logs, seems that sometimes Kodi does not return the current audio stream on first call on your device, probably some slowness inside Kodi.

Will need to find a way to reproduce that :frowning:

Hey,

thanks for the quick Feedback. Please find the answer in the following Screenshot :slight_smile:

Your explanation makes sense, just curious as to why this came to be an issue at some point (would have expected that with earlier Kodi versions). If this really is the case, maybe a slightly delayed 2nd call would help?

Edit: Libreelec is running on a RPI 3, just FYI.

There’s already other calls, but Yatse does not consider this as state change as it was not supposed to be changing for a single media.

Will see how to properly handle this without impact.

1 Like

Thanks for the explanation :slight_smile: Please let me know if/when you require anything from my side.

Just report if it happens with next release.

1 Like