Some images display a 'Play' symbol

external-issue

#1

I use Yatse a lot with the setup shown below to push videos and images up to a screen for training. In general it works very well. I have the setting ‘Synchronised with player’ set to OFF.

I’m finding that sometimes certain images (generally jpgs) don’t appear as images when they are swiped upwards to go on to the screen. Instead a large grey icon appears (like a PLAY icon, arrow to the right). I can’t see anything special about the image file that might make it give a problem.

Has anyone seen this before? I’m wondering what generates that PLAY icon. Is it Yatse? Kodi?Play%20arrow

Yatse v8.1.8
RPi BCM2835, Kodi 17.6, Armv7 Rev4
Libreelec 8.2.5


#2

This is Kodi :slight_smile:

But without logs (Yatse and Kodi) it’s impossible to tell anything more.


#3

Thanks, I should have posted logs in the first place. I’m part way to better understanding this now though, as I have been looking in the logs.

Kodi is mistakenly thinking a certain file (jpg image) is a ‘movie type’, hence the attempt to PLAY it. And the play icon. The jpg is not a progressive type, I did investigate that.

But the situation is even stranger. I can put say six copies of the same ‘problem’ file in the folder (which also has some videos mp4). I changed one to greyscale, reduced the resolution on another one etc. In doing this the file name of course changed. All these file versions displayed correctly.

Then I simply changed the name of the problem file, and it worked. I took a working file and gave it the problem name ‘Fin chop to face.jpg’ (medical image!) and it became a problem.

I have cleared all smb shortcuts, and cleaned the library. I will try and take those files to another RPi Kodi unit I have.

I’m not expecting a solution here, I’ll investigate further and use the logs. I thought I’d post a quick update in case it was of interest.

Note: The folders on the USB drive do not have CONTENT set in Kodi. The folders have images and short videos. In general this all works correctly. The skin is Xonfluence.
I will try it with the standard Confluence and see if that makes a difference. [Tried Confluence and Estuary, no difference - same issue].

File does not work
02:23:43.190 T:1816130464 DEBUG: Skin Helper Service --> Kodi_Monitor: sender xbmc - method: Player.OnPlay - data: {“item”:{“title”:“Fin chop to face.jpg”,“type”:“movie”},“player”:{“playerid”:2,“speed”:1}}

File displays correctly
02:23:43.161 T:1772090272 DEBUG: Skin Helper Widgets --> Kodi_Monitor: sender xbmc - method: Player.OnStop - data: {“end”:true,“item”:{“file”:“smb://192.168.168.30:445/SANMINI/SLS_FAVOURITES/First Aid Handout - Bites and Stings V2.3 Page2.jpg”,“type”:“picture”},“player”:{“playerid”:2}}


#4

This is a strange Kodi bug :frowning:

I’m aware sometimes they can badly identify media, but never heard of this happening because of the name of the file.


#5

I did some further testing on this, and it seems repeatable on another completely clean system.

I loaded an original 8.2.5 Libreelec image to a memory card and did a very basic setup on a Raspberry Pi. I kept all defaults, including the Estuary skin. Connected Yatse to it, and set up an smb shortcut to the folder on my USB drive. I then accessed this through ‘files’ on Yatse.

Sure enough, the image ‘Fin chop to face.jpg’ would not display. The other four or five similar images (smaller size, greyscale, different names) would. Through the Kodi file manager I changed the name, adding new to it ‘Fin chop to face new.jpg’ and it displayed. Then I removed the ‘new’ and it didn’t work again!

If I browsed to it via the kodi file manager it would display on screen correctly.

It is certainly a strange bug…
In the meantime at least by changing the name it seems to provide a solution. I recall a similar problem with another file not displaying when I needed it to. I’ll try a rename in future if it happens again.
I have no idea where to feed this into Kodi in case it helps bug fixing, but it does seem repeatable.


#6

As said if you do not provide complete Kodi logs there’s nothing I can tell or do :slight_smile:


#7

I’ll generate some Kodi and Yatse logs for the clean system.
Thanks!