[SOLVED] Problem to cast to my device with Kodi

and first thanks for your amazing app!
Everything was working perfectly during a year but now, i can’t cast to my device with Kodi in Upnp

Issue description:
I use a Puridea W1 to watch my movies. I connect it to my Network, then i go to Yatse, i look for avalaible players in the Cast icon up right, I choose my Puridea player. Then i go to “Files” in Yatse, l click on a movie from my https Web server. Then the movie seems to start, but after 2 seconds of black screen, it stops. Same with all my videos.
I precise all these videos are working perfectly with Kodi alone without casting to my device with Yatse

This is a screenshot of my parameters in Yatse for streaming and Upnp for Kodi

Additional information:
Kodi 18.9 with LibreElec OS 9.2.6
Yatse Pro 10.7.1


Kodi returns direct urls from your server with login and password.

Most UPnP clients do not support authentication in urls. Are you sure you did not change anything on Kodi side configuration?

From Yatse side of logs, everything works as expected there’s no usage of Kodi UPnP.

Thanks for the answer.
I am totally sure i change nothing on Kodi side, it was always with username and password.
To be totally sure, i have changed the access to my server with no authentication and it is the same problem. So i will look maybe in Kodi’s log…

Kodi is not involved here. Kodi just gives an https link to Yatse and Yatse sends it to your device that seems to accept it.
Then the device can’t play the media. Could be the certificate, the authentication, the codec or the missing duration returned by Kodi that your device do not like.

1 Like

You point out to my eyes the problem!
I have tried url without certification (http so) still with authentication and it’s working.
So it seems my device doesn’t like my let’s encrypt cert anymore :pensive:

Anyway, thanks A LOT for the precious help even if it’s not a problem related to yatse.