Smart sync not syncing subtitle files from Plex server

Issue description:
I am syncing from a Plex Server. It shows 3 subtitle for the episode. One embedded in the mkv, 2 on separate file, and the filenames like: episode.mkv,,
Yatse not syncing the files, only the mkv

Logs: (11.0 KB)

According to those logs the subs are correctly downloaded.

I’ll need logs when you try to play the media.

Media info xml from Plex (1.4 KB)

As said I need Yatse logs when you actually try to play the media, those subs are properly synced by Yatse!,

yesyes, I’m on it, I not seen your comment until I uploaded the plex xml, sry :slight_smile:

Here is the new log. I’ve regenerated from the beginning. (15.7 KB)

further information: if not synced, but streamed, the subtitles working correctly, generated a new log for that (10.5 KB)

Ok thanks so seems Yatse fails to send the sub list to Mx Player will need to investigate but I have enough logs to reproduce in theory.

Ok so actually it’s Yatse sending the subs to the Downloads folder even when not enabling that settings.

Will be fixed for next release, but you can add them in Mx Player they will have proper naming to find them easily.

Thanks, found them :slight_smile:
this will fork for me, thank you!

Beta with the fix was approved by Google you can get it on Play Store.

Sorry to say, but there is another problem now:
The files are in correct place, but because the “?X-Plex_Token=” part, the player app not seeing them. If I remove that part, then it works fine. (14.7 KB)
(I stopped the debug before the rename, but if you need it, I’ll generate another log)

Arf I called the wrong cleanup function :frowning:

Will fix and send you an APK tomorrow.

Thanks! But no need to hurry, I’ll be fine until the next update, not a big trouble to rename the files.
Thanks for the fix in advance! :slight_smile: