Slow when streaming or downloading outside local network


#1

When I try to stream or download from my Kodi library from outside my network, it takes forever, or just buffer.
This also happens if I connect to my external IP, but both server an yatse on same WIFI.

My internettspeed is 100 Mbps up and down, and I have tested several times with speedtests, and there is nothing wrong with the line.

Any idea of what can be the problem?


#2

Without logs impossible to tell anything :slight_smile:

But if you have issue during streaming Yatse is not involved as soon as the video is started. So the issue is general.

Only issue could be something slow on your router like a buggy firewall that does deep packet inspection when going from outside to inside.


#3

So do you mean that as long as the video starts, even if it uses a long time to start, and also just stutters when playing (showing one frame for about 10 seconds, then another frame, and so on), the app is not the problem?

I have tried to turn of the firewall both in the router, and i windows defender, but still the same problem.

Do you need the log if the video starts?


#4

Yes unless Yatse would completely bug and be in proxy mode but I doubt as it works in LAN.

Logs during download could give more indications about the issue, as download is made via Yatse.
Maybe we’ll see dropped packets or something that could help narrow the issue.


#5

While waiting for your reply, I turned of the firewall in my router, and that seemed to be the provlem. Now the video starts, both streaming and download, but the download speed is not very fast, 2-3MB/sec, and my upload speed can be much higher

But I dont want to have the firewall turned of. Any tips? Its a asus rt-ac66u with latest FW.
I know that is not your problem, but mine, but maybe you have any tips? also maybe how to improve speed?


#6

Well I would have said to try openWRT but it’s advanced stuff and it seems your model is not fully supported :frowning:

https://openwrt.org/toh/hwdata/asus/asus_rt-ac66u

You are maybe reaching the limits of this hardware :frowning:


#7

That sucks… I was told that this was one of the best routers when I bought it. Even if its a few years ago, it should be able to transfer files without problems.

Maybe I should upgrade my router, but since I dont know excactly what is the problem, I may buy a router with the same problem… :frowning:


#8

Well maybe there’s forum posts that will describe obscure settings that fix the issue.

I usually avoid making ads here, but personally I use an ERL-3 lite and it’s quite nice for the price and can handle way more than your 100Mb (I have 1Gb :wink: here)

coupled with some

It’s a little more advanced but I’m more than satisfied with it.


#9

Thanks for the tips. Was looking for something in one package, since it’s not a big apartment, and the router will be visible in the livingroom.

But I will try to keep troubleshooting, hoping to find a solution…