Since update to 9.5.5 Yatse hangs in a boot loop

Issue description:
Since I updated Yatse to the latest version today it won’t start anymore on my device and the screen stays black. I can only see the Android notification bar. Sometimes even the navigation keys on the bottom edge get hidden so that I have to reboot my phone to make it usable again.
In some rare occasions the screen instead kind of flickers when I start Yatse so to me it seems that there’s maybe something wrong with that “new version, here’s what changed” screen. Seems like it wants to show up but get’s killed instantly and then retries infinitly many times.

Unfortunately can’t provide any as of now, since I can’t even access the app, not to mention the settings menu. I only can say that I’m on Android 8.1 and everything on my device is stock, so not rooted or whatever. And Yatse has served me well up until this day.

Would they be of any help?

Additional information:
The rest of Yatse (as far as I use it) seems to work. So I can send links to video streams via share to my devices and I can see what’s currently playing in the notification. It’s just that the main activity refuses to start up.

Yes there’s a rare case when you have changed the start page to something not accessible when Kodi is offline and Kodi too slow to answer.

I’ll try to push a fix in the coming days, but you can start the app by long pressing Yatse icon then selecting movies then change your start page in the settings.

Thanks, that did the job :slight_smile: Could this be the same reason for Yatse occasionally showing the remote page instead of my set start page lately? I have Yatse set up to show the overview start page because I like to see everything at a glance. I thought Yatse would populate the content on all that pages based on the offline data it already synced to the device. Isn’t it? I can hardly imagine that since Yatse worked flawlessly in the past (and so did the overview page) even at places where I hadn’t my media centre available at all. Anyways, as I see it, I’ll have to change the start page to something different from the overview page ‒ since this is the only one that breaks Yatse on my device ‒ until there’ll be a fix.

Thanks for the heads up.

The overviewpage causes this? Hum this is not normal.

Do you use the automatic offline mode option too?

I am sorry for any confusion I may have caused. I misleadingly said overview page but what I meant was the “home” page. At least it’s called “Home” in my german version. I compiled two debug logs for you in the hope that they could be of any help for you.

For debug log #1 I set the start page to “Movie (overview)” page as the inital state. I started the app, then I went to settings and changed it back to “Home”. When trying to leave the settings menu I was stuck there until I switched the start page back to “Movie (overview)”.

For debug log #2 I left the page set to “Home”, terminated the app from the Android menu and then tried to start it the normal way by clicking on the icon. Nothing happened, the screen stayed dark.

And no, I don’t use the auto offline option.

Following up by PM to send you test APKs.

Solved in 9.5.5a that should be accepted by Google in the coming hours.