Scrobbling from Yatse app to Last.FM app stopped working

Issue description: Since last update songs played on my Pixel 3a through Yatse will not be detected by scrobbling apps like Last.FM and other third-party options. Connected through to Plex. Tried resetting Yatse and other apps to no avail, still won’t be detected like before. Thank you for your time.

Logs: (13.0 KB)

Logs does not show issues and that part was not changed since ages.

Like before when ?

Since before the last update to Yatse, it worked very well, then immediately stopped working once updating to 10.6.0. It’s strange because all other media apps will be detected by scrobbling apps but it’s possible a concurrent Pixel 3a update changed something, or perhaps Nova Launcher too. I also changed logging into my Plex account to directly connecting through an IP around the same time, as Plex’s WiFi to network switching was annoying. I’ll do more testing and if it starts working again I’ll post back what happened.

Okay it’s working again, I just had to cast the stream to my phone from this menu. Forgot about this, I must have reset it at some point.

When casting to other device you need to enable the option scrobble when streaming.
It’s off by default to avoid double scrobbling.

That option was always on, now after getting it to work through casting to the phone itself I’m facing more confusing issues like the Plex app playing instead of Yatse. I think I’ll just chalk it up to some phone weirdness and deal with scrobbling not working for now. Thank you for your help, though.

Edit: I downgraded to the previous version and it started working perfectly again. I’ll mark this as the solution for anyone else coming across this post.

Downgrading is never a solution to anything it just prevent any future updates …

Please describe better what you are doing as you last comments sound a like like a misuse of Yatse and understanding of the streaming part.

Hi @Tolriq!

I think I’m experiencing the same problem, on both a Pixel 5 and a Pixel 3XL.

When playing songs locally using Yatse they are no longer being announced correctly to Android, whereas using something like VLC, they’re detected straight away.

Here are my Yatse logs: (2.7 KB)

I originally reported this to the developer of Pano Scrobbler, who said “According to the logs, the artist is null. Stuff without an artist cannot be scrobbled. Looks like your player is sending incomplete metadata to Android.”

Happy to provide any other details or run any other tests you need!

I need logs that reproduce the issue.

Once logs are enabled start playing a song until it’s finished.
I’d like a screenshot from the notification too and what the pano scrobbler see / logs you send them.

No problem - here’s a log for a song played locally from start to finish: (7.0 KB)

There was no notification to take a screenshot of - no scrobblers react at all.

Here’s a Pano Scrobbler log from during the song:

pano-scrobbler-yatse.txt (9.2 KB)

You can see I played a local copy of the file with VLC, and the metadata was picked up correctly, and then further down the log I tried to stream the copy of the song on my NAS with Yatse and it’s missing the artist details.

I did try to stream the same song from the NAS with VLC, and it seemed to hit the same problem, so I guess this isn’t Yatse specific - it must be something to do with how the Pixel is streaming stuff?

Ok thanks for the details and logs.

It’s effectively missing artists on some cases and Yatse not applying a fallback to calculated value.

Will be fixed for next release thanks @yamiacat and well not thanks to @Maghook :wink:

1 Like

I just got the new release and scrobbling has indeed been fixed!

Many thanks @Tolriq, I really appreciate it! I’m gonna go make a donation now! :grin: