Remote navigation with event server and MrMC on TVOS


I have a question regarding the remote implementation and MrMC with event server on TVOS. Is it a known issue that MrMC doesn’t recognize any button presses of the Yatse remote when the event server option is ticked? When I try it with Kodi it works, but not on MrMC. Is there a limitation on their side?

The event server in MrMC is up and running:

18:27:05.152 T:6114013184 NOTICE: ES: Starting UDP Event server on
18:27:05.152 T:6114013184 NOTICE: UDP: Listening on port 9777

When I check the network traffic with WireShark I can see that Yatse is sending out the packets. As example:

R1 up

I also have another question. Can I change what Yatse sends with disabled event server option? I ask because when watching Live TV MrMC changes the channel with the up and down key, but Yatse sends other keys when watching full screen video:

19:14:53.450 T:6136655872 DEBUG: JSONRPC: Incoming request: {“id”:226,“jsonrpc”:“2.0”,“method”:“Input.ExecuteAction”,“params”:{“action”:“chapterorbigstepforward”}}
19:14:55.007 T:6136655872 DEBUG: JSONRPC: Incoming request: {“id”:295,“jsonrpc”:“2.0”,“method”:“Input.ExecuteAction”,“params”:{“action”:“chapterorbigstepback”}}

Also for the left and right arrow.

Here are all versions I am using:

TVOS: 13.4.5
MrMC: 3.9-6
Yatse: 10.2.5B2
Kore: 2.5.0

Without the mandatory full logs there’s not much I can tell :slight_smile:

But it the packets are sent then yes the issue is on MrMC probably a broken keymap file.

But no you can’t change the associated action when not using Event Server.

how can I share logs without being visible to all viewing that thread?

I already tried creating a custom yatse.xml keymap in the keymaps directory in my profile, but somehow it’s still not working.

<?xml version="1.0" encoding="UTF-8"?>

or I am missing something?

By default logs are sent to support email :wink: + private message here.

For the keymap the default one is used R1

can I get that R1 keymap somewhere if they perhaps stripped that out or something?

I will try to post that log now. :slight_smile: Maybe you used some addons, but this is more support for their forum than Yatse :slight_smile:

Yeah, I hoped that someone already had that issue and know what to do. I hope they can help me out in the MrMC forum. Thank you very much for your time.