"Problem with event server : check kodi settings"

Hi,

Since some days, Yatse doesn’t work anymore with my Kodi 17.6 on Windows 7 PC. I found a workaround by unchecking “use event server” in Yatse server setting, but you don’t recommend that and i would like to understand why my event server doesn’t work.

So, with “Use event server” checked, if i start a “check” in Yatse server setting, i have the message i wrote as post subject.

I use another remote device to control Kodi : a physical remote control with the windows software eventghost installed on my PC.

After i ran the “check” in Yatse setting, Eventghost stopped working too.

I found why : eventghost work only if i"allow control from applications on others system" (kodi setting) is disabled.

The thing is that Yatse check auto enable it, so my eventghost dosn’t work after that. And Yatse doesnt’ work better with or wothout it.

I watched kodi logs and this setting seems to have an effect on IPV6 use :

When enabled :
NOTICE: UDP: Listening on port 9777 (ipv6 : true)

When disabled :
NOTICE: UDP: Listening on port 9777 (ipv6 : false)

I don’t use Ipv6 on my network connexion (or i don’t know) : i use ipv4 static ip adress.

What do you think ?

Thanks

  • Short answer:

On some cases there’s bug in Kodi with IPV6.
Kodi only listen to IPV6 and forget IPV4. You can disable IPV6 on your host to fix that if you do not use it.

  • Long answer:

During test, Yatse auto check the option since 90% of users do not read the doc and do not check it :wink:

Event ghost use Event Server on localhost so depends on another settings that normally only binds to localhost IPV4. When enabling the option “allow control from applications on others system” , Kodi binds on all interface but enable IPV6 if available and on your device fails to bind IPV4 on some devices so that breaks EventGhost too.

I think Kodi 18 may have some fix about that, but easy solution is really to remove IPV6 from your device if you do not use it, as it’s a pure Kodi bug.

Thanks for your quick reply.

I tried to disable ipv6 by adding this code to my advancedsettings.xml :

<network>
    <disableipv6>true</disableipv6>
  </network>

Issues are the sames. Is it the good way to disable ipv6 on Kodi ?

So it could resolve my eventghost issue, but what about Yatse : it doesn’t work with or without “Allow control from applications on others system”. It only work if i uncheck “Use event server” in its settings. Should i do that and wait Kodi 18 ?

I think to something maybe important : my router is a “Livebox 2” . Maybe it doesn’t support ipv6 and could be the cause of issue between Yatse and Kodi ?

All is tied to Kodi as I tried to explain but I suppose you do not have the network knowledge to understand all the links :slight_smile:

You need to remove IPV6 from your OS on all interfaces and it will work for Yatse too.

https://kb.iu.edu/d/aqig or https://tweaks.com/windows/40099/how-to-properly-disable-ipv6/

In all cases Yatse fully works without EventServer, you loose only a few things, most still works (Some custom commands won’t work, Atempo won’t work and some things like that), but if you do not use them it does not matter, and in all case you are now aware of why they won’t work or be present.

I disabled ipv6 by unchecking line on my network card and by registry. After reboot, i have the same issue (Yatse message about Event Server).

So i decide to uncheck “use event server” for make Yatse working, and disable “allow control from applications on others system” to make Eventghost working.

Thanks for your help,
Have a nice day.

If Kodi still says IPV6 then you have not disabled enough :frowning:

In all cases if checking the option break eventGhost you should report to Kodi team, bugs don’t solve by magic.

Hi,

You’re right, kodi log always show ipv6 NOTICE: UDP: Listening on port 9777 (ipv6 : true)

I will try again with Kodi 18.

Thanks