Problem of DSD audio file & DLNA renderer

Hi,

I use Yatse to play music from Emby server to DLNA renderer (Integra receiver DRX-3, Sony speaker SRS-HG1, KODI on Windows). When playing FLAC audio files, everything is great. But when playing DSD (dsf extension) audio files, Integra receiver and Sony speaker can’t play them (and then play the previous track).

After checking Yatse’s log files, it seems mime-type problem.

SONY SRS-HG1 accepts audio/dsd, audio/x-dsd for DSD files.
Integra DRX-3 accepts audio/x-dsf, audio/x-dsd, audio/x-dff for DSD files.
KODI seems accept everything no matter what?!

According to the last response ( DSD dsf File Support for Emby Direct Play on Sony Blu-Ray UBP-X700 using DLNA and Remote App ), DLNA controller seems have to provide the correct mime-type for renderer.

Three logs attached. I played one FLAC file and then one DSF file in the log.

Sorry for my bad English and thanks in advance.

debug.integra.log (564.0 KB)
debug.sony.log (445.2 KB)
debug.kodi.log (695.1 KB)

Seems Android does not know that mime type by default.

I’ve added it to the overrides, please test attached APK that should send the proper one.

Yatse-beta-arm64-v8a-final.apk (8.7 MB)

I tried this beta version on Sony speaker. When playing dsf audio files, it still doesn’t play the music (but plays the previous track). I check the log file, and the mime type is correct but Sony speaker still responds error. What can I do now?

Sorry that Integra receiver isn’t here for me to try now.

debug.sony.2.log (574.4 KB)

You can try to check back the option alternative dlna headers in Yatse settings that is on by default.

After that no ideas sorry.

Hi,

I tried to enable and disable the option alternative dlna headers in Yatse settings, and all the same results. I also tried to play on Integra receiver last night, and no luck, too.

debug.integra.2.log (678.5 KB)

I set up a MinimServer 2 on local network for testing, it can play dsf audio files after overriding mime-type setting (mimeType.dsf=audio/x-dsd) with Bubbleupnp app. In the following log, the mimetype of the first playing song is audio/x-dsd and the Sony speaker is playing the music, and the mimtype of the second song is audio/x-dsf and the speaker can’t play. The Integra receiver has the same behavior. So strange.

com.bubblesoft.android.bubbleupnp_log.sony.minimserver.1dsd2dsf.txt (128.7 KB)

Thank you very much anyway!!!

I don’t see a difference :frowning:

Only thing I can think of is that there’s an issue on Emby server side with the header it serves that generate this.

Try to download the file to Yatse then stream from Yatse the dsd file to see more and have more control on future tests.

I download flac & dsf files to my mobile phone. When I play flac audio files from “MUSIC” list, everything is great, but when I choose “FILE” and then choose any of “primary:*”, it can’t play anything (both flac & dsf). I check the log, and the mime-type for the audio files is video/mp4.

Android don’t know DSD audio files, so it won’t add dsf files to the “MUSIC” list. (I think)


In the log, the first playing song is in the “MUSIC” list. and the second (flac) and third song (dsf) is in the “primary:Download/Yatse” list.

debug.yatse.local.log (303.9 KB)

Anyway you can also just shutdown Jellyfin and use the normal Jellyfin view to cast and Yatse will use the offline cached files for play.

Edit: If you do not use the option download to download folder

Edit2: Bug for file mode found and fixed (but missed the 10.9.5 release window)

I update Yaste to 10.9.5 and shutdown Emby server for testing. It plays FLAC files, but it still won’t play DSF files. I check the log file. In line 2053, the local DLNA server seems repond wrong mime-type (Content-Type: application/octet-stream) for dsf files. Log attached.

So, when connecting to Emby server and not playing dsf files, it should be the server’s problem, I think.

debug.yatse.10.9.5.embyshutdown.log (304.0 KB)

About file mode, if I play from Android’s multimedia center (I don’t know the correct name in English, sorry!), it plays flac great. But if I play from the directory that I manually added in Yatse, it won’t play flac & dsf. (Yatse 10.9.5)


debug.yatse.10.9.5.filemode.log (286.3 KB)

Thank you very very much!!!

Ok thanks for the first test, seems I missed a place for the extension handling.

For the second issue as said it’s fixed but you reported too late for the fix to be in 10.9.5 will be in next version.

I’ll fix the webserver header on my side to confirm and send you and APK in probably tomorrow or Monday.

Oh I see. Sorry for my misunderstanding, my bad English.

Thanks in advance.

So Week End is a little delayed by the weather :frowning: Please try attached APK.

Yatse-beta-arm64-v8a-final.apk (8.7 MB)

Wow it’s working!!! I tested on both Sony speaker and Integra receiver, and flac/dsf audio files are all playing correctly.

Thank you very very much!!!

debug.local.sony.working.log (387.9 KB)
debug.local.integra.working.log (640.0 KB)

Well will still need Emby to have the server part fixed when streaming from it. Nothing I can do for that proxying the data would kill the phone battery for nothing.

Yes I see. I’ll take the Sony speaker back with Emby server on the same local network to test. Hope Emby can fix it. Thanks again!!!