Problem casting Jellyfin content to Chromecast with Yatse

Hi there,

Now I’m not sure if this is a Jellyfin or a Yatse related problem/question, so corrrect me if I’m wrong.

Since the Jellyfin Android app is terrible at casting, I thought I would give Yatse a try with the free demo. Now I’m using my friend’s Jellyfin NAS/server for the time being because I first wanted to know how Jellyfin worked with casting content to Chromecasts before buying and configuring my own Jellyfin (or related) NAS/server (in my household we all cast our content to our Chromecasts connected to our TVs).

Issue description
When I start casting content from the Jellyfin server with Yatse to my Chromecast, it works fine at first for a minute or so. After that it starts loading indefinitely. So I was thinking maybe it’s something to do with the subtitles, but I don’t think that’s it because I have the same problem without selecting subtitles. Also tried viewing the content locally with subtitles (via Yatse and VLC) but that works just fine. So I don’t really have a clue anymore.

I don’t really have anything else than the Yatse logs because it’s not my server but my friends’. (43.6 KB)

Hopefully it’s fixable and otherwise I just have to give up my hopes for a media server/NAS for casting.


Once the stream start Yatse is not involved it’s between the Chromecast device and the server.

The server probably does not have enough BW to stream the media.

Hmm okay. Still a bit weird why it’s not happening on my phone or PC or on any of his devices.

Will keep trying something else then, thanks for the answer.