Playback problems with UPnP

Issue description: I am using Yatse on Android as an UPnP controller to play music stored on the Kodi device (Libreelec on RPi4) on an UPnP renderer (upmpdcli on RPi1b). This works in general, but I am encoutering two issues:

  • When I select a different song from the music lib while currently playing a song, the newly selected song will not start from the beginning, but from the position the previous song was currently playing at (e.g. if song 1 plays at 2:55 once I select song 2, it will start playing from 2:55).
    I did this a couple of times, should be recorded in the debug log. The last time I selected a song which was shorter than the current playing position - in that case the selected song started from the beginning.

  • When I select the first (or any) song of an album, subsequent songs will only play when I wake the phone. A message appears then (“preparing media for streaming” or similar), but that does not seem to work when the phone display is off.
    Interestingly I could not reproduce that problem with debugging turned on - maybe Yatse is not sent to the background then?
    I assume this might work better if I configure Yatse to not be put to sleep in the Android energy settings (did not try yet). But I wanted to ask if it is also possible that Yatse sends the whole playlist to the UPnP renderer instead of sending each song individually once the previous song has ended (I think UPnP supports something like this)?

Logs:
(removed after solution)

Screenshots:

Additional information:
Apart from the above usage, I use Yatse almost daily as a remote for my Kodi installation and enjoy it every time. Thanks for a very well crafted app!

Point 1 is already fixed in next version (you can join beta)

Point 2 is a bug from Samsung they do not respect wake locks on some OS / devices so yes you must put exception on Yatse. When in debug mode Yatse write to the storage this makes Samsung think Yatse is not idle, but this does not correspond to anything standard, just some absurd Samsung bug.

And no UPnP does not support playlists, just some devices support preparing the media after the current one but this is not enough for normal usage.

But you also have a configuration problem, you should disable the option force upnp force streaming and fix your Kodi sources to ensure streaming works without having to do slow resolution between tracks.

Ok, I will try beta, thanks.

I am not sure I understand you right regarding the configuration problems. The option “force upnp streaming” is off in Yatse. “Alternative DLNA parameters” is on - should I turn that off?

Ho yes sorry read the logs too quickly you are in the second case of Kodi with login / password and upnp not supporting that forcing the switch to the upnp server of Kodi.
If your Kodi is not open to internet and your network relatively secure you may want to remove Kodi password to remove delay between tracks.

Beta release (now a full release) helped for point 1.

Regarding point 2, there is two kinds of energy tweaks in the Samsung settings.
One is Settings -> Device Care -> Battery - > App power management -> Apps that won’t be put to sleep. I added Yatse here, but it did not help with point 2.
The second one is to go to app info (long press on app icon) -> Battery -> Optimise battery usage -> disable. This seems to control the wake locks you mentioned and actually seemed to help with point 2. An app for which battery optimisation has been disabled cannot even be put into the list of “apps that won’t be put to sleep” (probably because all energy management options have been turned off for this app).

Thanks for pointing me the right way here!