No subtitle while streaming from pc to samsung smart tv

Issue description:
The subtitle doesn’t show up while I’m trying to stream from kodi on a pc to samsung smart tv using yatse on my phone even though the subs are in the same folder as the movies video.

Another question, is there a way that i can search subtitles and download them in the movie folder? coz um using an old pc as kodi server, and i use yatse to stream from this pc to different TVs around my house.

Screenshots:

As the template says please provide logsssssssssssssss :slight_smile:

And to download the subs use Kodi subtitle addons :slight_smile:

debug-20191125_204202.zip (119.0 KB)
This the debug file…
And i meant searching for subtitles and downloading them to the movie folder from inside yatse so i don’t need to use the PC.
Regards,

There’s a few issues

  1. The host name should not have the \ in it, I’m amazed that it works with those
  2. Your Kodi is password protected and your TV does not support those kind of shares, Yatse have an hack to match and find the media via Kodi UPnP server but this hack does not work for subtitles.

Remove your Kodi password and add again the host without the \ and it will work. (At least Yatse will properly send data that your Tv have most chance to support).

For the download I know what you meant but this is not possible as Yatse have no access to the movie folder and it’s lucky for you as Kodi have no security and anyone could delete / create files.

debug-20191125_222630.zip (218.5 KB)
First thanks for your attention, i tried the instruction but unfortunately it didn’t solve the problem however another issue started which wasn’t existed before that the pause button doesn’t work and the progress bar refuses to jump to a certain point and shows message “not available” on TV screen.

Nice so you are also facing Kodi webserver issue :’(

You can enable the option Force UPnP for streaming to workaround that.
For the subs the data that Yatse sends is correct and contains the subtitles information.
Are you sure that TV support subtitles via UPnP does it works when played from Kodi to that TV?

Thanks That’s solved the issue with control buttons but didn’t help with subtitles i guess it’s my tv doesn’t support subtitles coz on chromecast it works just fine… anyway thank you very much for your help.

Please still try from Kodi if it works then with Kodi logs I may find a something specific about your TV and fix Yatse.